summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-10 05:48:59 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-10 07:03:12 +0200
commit8a45e348d3c10f18d0f902fdafd5225a7100a6c7 (patch)
treef0ac89c899a8a08e1d5f9e40ad5821e6929eb7f3 /app-admin
parentdev-python/boto3: Bump to 1.35.37 (diff)
downloadgentoo-8a45e348d3c10f18d0f902fdafd5225a7100a6c7.tar.gz
gentoo-8a45e348d3c10f18d0f902fdafd5225a7100a6c7.tar.bz2
gentoo-8a45e348d3c10f18d0f902fdafd5225a7100a6c7.zip
app-admin/awscli: Bump to 1.35.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.35.3.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 1a94f5e68c8a..ca4bf7cb655a 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -7,3 +7,4 @@ DIST aws-cli-1.34.33.gh.tar.gz 2804264 BLAKE2B a3c45f08ffa977d727c0a5c3e7c7d1391
DIST aws-cli-1.35.0.gh.tar.gz 2806480 BLAKE2B d607933a9baa0e50ab8d809e0ecb68681e90815fca7db6b69b01a632a56d37a62bedaf6dc981bffaa0206b31b6ca84b3d5e3524289b9b2edc55ef1989239a696 SHA512 2008b00455755b3c332b83d6df3e86f461a94b401aeb022887feddd6f5f3ab439b382d24d46c4e0da825df24899ede6307c4e482987d07171d38704c85ac4eb1
DIST aws-cli-1.35.1.gh.tar.gz 2806870 BLAKE2B 93728164035382e95bc3a181b2f36b1c6509abf7084efa8210518ddd1d5c38343b860eef5e69e0faf6119445060c9281a29c5e6c623b8ab5d25f5cefb85d989b SHA512 86ddb82f2d22e5c330a6cac58568eda63065f4b77621534040203866825e97df583d1d5637b7b12f8ffac68e9f42e79d2c0a1f3abb192c121a8fc8bf773fc5e5
DIST aws-cli-1.35.2.gh.tar.gz 2807621 BLAKE2B edaa14c648871d2d769ba90305d6c545710ade9c4724cd698c32b9c83a0611808e6fbae1dc052da5656804314dcc34479cddfac770997e2123c6afcabe82cb64 SHA512 148a203860e03a630bfcd4a6f1bc39be70bc9180e06fc6f7380d1a7678365a4d94de89f138bec7430575bfd84ab490020d72a735796b41a91f2caf4164abeee8
+DIST aws-cli-1.35.3.gh.tar.gz 2807624 BLAKE2B 31e2be1970828517b20e6fafc3d4d2c759ff95c5cfee3ed4f1544d15e5f239559db84b5a5989e041cf075d2b237a973725126b3dd459733ffdce533d9162b30f SHA512 37379490fcb86a1973f040730b4b34b572a24be6f51c42476e10db9a83121da36eb4d0cf0e57015212a97471b9d2b9bd892dee654c2585c2d166ff4f7b74516c
diff --git a/app-admin/awscli/awscli-1.35.3.ebuild b/app-admin/awscli/awscli-1.35.3.ebuild
new file mode 100644
index 000000000000..49e2e891cd54
--- /dev/null
+++ b/app-admin/awscli/awscli-1.35.3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.y.(z+34)
+BOTOCORE_PV="$(ver_cut 1).$(ver_cut 2).$(( $(ver_cut 3-) + 34 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}