summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-09-15 13:59:41 -0700
committerSam James <sam@gentoo.org>2024-09-19 02:25:50 +0100
commit8d451eba6104c0f6beff981f48b47bb7e5d1d4ab (patch)
tree1541bc95302b716a80f330ef5ec491324e8d8c13 /app-admin
parentapp-admin/ansible-lint: add myself as a maintainer (diff)
downloadgentoo-8d451eba6104c0f6beff981f48b47bb7e5d1d4ab.tar.gz
gentoo-8d451eba6104c0f6beff981f48b47bb7e5d1d4ab.tar.bz2
gentoo-8d451eba6104c0f6beff981f48b47bb7e5d1d4ab.zip
app-admin/ansible-lint: add 24.7.0
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible-lint/Manifest1
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.7.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 6d824b7aaf37..3d8b190d5d1b 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,2 +1,3 @@
DIST ansible-lint-24.2.2.tar.gz 515822 BLAKE2B e9d8e689dfe4e4efbd4dad44ff3567f50412400ed979f2d60150f09f17c5f63f2441f25a33ecdf0112024ced07e62ac16b8a2dbc1c01d62855ec785fc75d1b9a SHA512 3de6b14e4b64ba577abcb67920a45dbf45fedb84e21091cd6a29e3c52a7a91555a152ee3e265624aafbf9dddba96d04241c2598a18f2103ce2cae48706142446
DIST ansible_lint-24.6.0.tar.gz 529088 BLAKE2B 3d307669d2035eb5a3a8295b40e3afca92ca4eae4ea419948fd2fa86127e05c60f3ca037a4b85b447320ba8a57f7e1a736a55d63aac80e386f9fc4d733190b09 SHA512 1eb8e3e1805ff98ae76ddcd873a5e90b0b0182fbbce3c40844b2a9069e6879fef906e14f98dd77e41372e461ea4350388b68e08be420afaf5d6c449a449a7989
+DIST ansible_lint-24.7.0.tar.gz 530977 BLAKE2B bc6b98b2372dc58bedc8fc305ebad72e75bddf980906789f51f8dde9eda9b2f51ad3397b8dc2bb5712c1abbf61d08a1a6ab5c1468d6ae10404846f952e2fc078 SHA512 1ba69c7fd2c29f89cc2526ad14ea6a7aff4a0715d3dddf0abc79d6dae9bc5ad02152bdece635684a0d1a805a816ea2f28b2a07c5570975bb73bfa332e8679109
diff --git a/app-admin/ansible-lint/ansible-lint-24.7.0.ebuild b/app-admin/ansible-lint/ansible-lint-24.7.0.ebuild
new file mode 100644
index 000000000000..057962e736a9
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.13.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-24.5.0[${PYTHON_USEDEP}]
+ >=dev-python/black-24.3.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.5.0[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}