summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-08-09 17:33:16 +0200
committerUlrich Müller <ulm@gentoo.org>2023-08-09 17:39:19 +0200
commit94c143cfc308eb0f883cd7d3ee2c036db76e3f10 (patch)
tree18a61a9836a6fcc158a2b0d1787f107df6aee83c /app-admin
parentnet-proxy/haproxy: Bump to 2.7.10 (diff)
downloadgentoo-94c143cfc308eb0f883cd7d3ee2c036db76e3f10.tar.gz
gentoo-94c143cfc308eb0f883cd7d3ee2c036db76e3f10.tar.bz2
gentoo-94c143cfc308eb0f883cd7d3ee2c036db76e3f10.zip
app-admin/eselect: add 1.4.26
Closes: https://bugs.gentoo.org/911792 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect/Manifest1
-rw-r--r--app-admin/eselect/eselect-1.4.26.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-admin/eselect/Manifest b/app-admin/eselect/Manifest
index 9c9b1e0d75aa..aa1d90e5335e 100644
--- a/app-admin/eselect/Manifest
+++ b/app-admin/eselect/Manifest
@@ -1 +1,2 @@
DIST eselect-1.4.25.tar.xz 184300 BLAKE2B 630fe27338bee0c921a2f90e42d0a8abbb60a141a82bc2c4e7cf43d37582c24b06986ae1cbd341f8d3e69d011edc6c29675bf91ceaf1dcbc2593086f451b8f5f SHA512 98f2752d61e2c31ff6d735d5df0e7d98c3cc51d51c26b71d796948b141ccbc017002185022e6e1e48660ae0012bfc9cd383dd5ac50f644b35bb0893b9271121b
+DIST eselect-1.4.26.tar.xz 184332 BLAKE2B ee1e8890802fc50646c8d1d5219f1ab0ec5cfc0138c758f73ad6baccf673992bbf3e763d8e84491f33e724ba4e1cf3bed6971ba7fa4373e0f06464ff4a5fa1e6 SHA512 397ae2f15d90d722eb84225b08f1afaaf6f89758bfae5d93b0a1c3eddc997c21e74ab62e09ee5e71941d3a8587b3372b64336d12054c3bbf0e56e1ba398a26f9
diff --git a/app-admin/eselect/eselect-1.4.26.ebuild b/app-admin/eselect/eselect-1.4.26.ebuild
new file mode 100644
index 000000000000..67427d8a317a
--- /dev/null
+++ b/app-admin/eselect/eselect-1.4.26.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Packages sharing a common release tarball:
+# app-admin/eselect
+# app-emacs/eselect-mode
+# Please bump and mark them stable together!
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
+SRC_URI="https://dev.gentoo.org/~ulm/eselect/${P}.tar.xz"
+
+LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-4.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc emacs vim-syntax"
+
+DEPEND="sys-apps/sed
+ || (
+ sys-apps/coreutils
+ app-misc/realpath
+ )"
+RDEPEND="${DEPEND}
+ sys-apps/file
+ sys-libs/ncurses:0"
+BDEPEND="doc? ( dev-python/docutils )"
+PDEPEND="emacs? ( app-emacs/eselect-mode )
+ vim-syntax? ( app-vim/eselect-syntax )"
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newbashcomp misc/${PN}.bashcomp ${PN}
+ dodoc AUTHORS ChangeLog NEWS README TODO doc/*.txt
+ if use doc; then
+ docinto html
+ dodoc *.html doc/*.html doc/*.css
+ fi
+
+ # needed by news module
+ keepdir /var/lib/gentoo/news
+ if ! use prefix; then
+ fowners root:portage /var/lib/gentoo/news
+ fperms g+w /var/lib/gentoo/news
+ fi
+}
+
+pkg_postinst() {
+ # fowners in src_install doesn't work for the portage group:
+ # merging changes the group back to root
+ if ! use prefix; then
+ chgrp portage "${EROOT}/var/lib/gentoo/news" \
+ && chmod g+w "${EROOT}/var/lib/gentoo/news"
+ fi
+}