summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-04 04:09:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-04 05:12:15 +0200
commitd2a72de4c49539ec901fe5026256b16b6ab4cd3b (patch)
tree29e667591229d6ac1c536dfd5e8aa34a7e92da75 /app-admin
parentdev-python/boto3: Bump to 1.35.33 (diff)
downloadgentoo-d2a72de4c49539ec901fe5026256b16b6ab4cd3b.tar.gz
gentoo-d2a72de4c49539ec901fe5026256b16b6ab4cd3b.tar.bz2
gentoo-d2a72de4c49539ec901fe5026256b16b6ab4cd3b.zip
app-admin/awscli: Bump to 1.34.33
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.34.33.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index ae3b246d4cd6..dd0626836af3 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.34.24.gh.tar.gz 2798088 BLAKE2B 24d5b74da8e6e1b97cd8c3558d28581ac
DIST aws-cli-1.34.29.gh.tar.gz 2800945 BLAKE2B 93d9b41dfb2d80546f6cd601ff339053b6fef760bf9359d56b2d3835c1a8cca21146b492100db611c1bbe8601ad143dde0490b86d63eba7707141a5ca0c6aecb SHA512 9174fbc0e552d708916080b8b3d5b6b1e871332ac2a8b65b27091745b4537120d97c99ced878c861960f81b8368cb564a1fe573c9dc528c343b2100fc0ea6b08
DIST aws-cli-1.34.31.gh.tar.gz 2802205 BLAKE2B dbdf6124a47756dc1ce93dafd3a3ceedfa8569a96e467cd2d5f44f42b642e5701e2bfb690000e01737ef126f554325998dd51b42007947848ce69512a0aafeb7 SHA512 4db1e625b1a64906b8c01371f594b32208e82c1d3eed59fb54aedddd147c64501b5d6f5d07c3483675a4bf81a0260be359b249f830fc084d7f04557760cd995c
DIST aws-cli-1.34.32.gh.tar.gz 2803375 BLAKE2B 199015e283253e53a911883da0f2303a13292813f436931e94b36f4aaf34578596409c9781c5bdd536557ca85ac749d2b2ded843a01889bca7fe2f08981ca3ad SHA512 f0d5bcc696294e5fa99eea098ec2d5523f3b1e5ea04ab08bfa9c98bf519b639d374990c1f67099ce81be7e095aed468c3d84128cd35938ceaf8be1141859409a
+DIST aws-cli-1.34.33.gh.tar.gz 2804264 BLAKE2B a3c45f08ffa977d727c0a5c3e7c7d1391faff6ae47f138577fc87be72250f4e2d01b8b4a446c89499be16f5248d53fdef75491965c11504917d2ef2e629a96d2 SHA512 c5dd06e908081ae70ebbc2228d2a2760b115d22afc26d890a3020f4807c4a646921aca0445909942a644a69928b38b1056c886db2d31d61a8e98abbebe08bc52
diff --git a/app-admin/awscli/awscli-1.34.33.ebuild b/app-admin/awscli/awscli-1.34.33.ebuild
new file mode 100644
index 000000000000..599b9bd389b9
--- /dev/null
+++ b/app-admin/awscli/awscli-1.34.33.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}