summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-28 16:04:51 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-28 16:07:24 +0100
commit44c2c7b3e4732cbcd4042c91134c1869477ccd76 (patch)
tree914156c0e887719fb7adec58a37b546c52f89d19 /app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch
parentapp-backup/vzdump: Port to EAPI 6 (diff)
downloadgentoo-44c2c7b3e4732cbcd4042c91134c1869477ccd76.tar.gz
gentoo-44c2c7b3e4732cbcd4042c91134c1869477ccd76.tar.bz2
gentoo-44c2c7b3e4732cbcd4042c91134c1869477ccd76.zip
app-arch/pure-sfv: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch')
-rw-r--r--app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch b/app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch
new file mode 100644
index 000000000000..ca2143f1f956
--- /dev/null
+++ b/app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -54,18 +54,16 @@
+
+ VC_CRAP = pure-sfv.ncb pure-sfv.plg
+
+-CFLAGS += -Wall -Werror -O2 -g -Wno-unused
+ INSTALL_PREFIX = /usr/local
+ INSTALL_PROGRAM = /usr/bin/install -c
+
+ all: pure-sfv
+
+-CC = gcc
+
+ OBJ = ${SRCS:%.c=%.o}
+
+ pure-sfv: $(OBJ)
+- $(CC) -lm -DVERSION=\"$(VERSION)\" $(CFLAGS) -o $(PROG) $(OBJ)
++ $(CC) -DVERSION=\"$(VERSION)\" $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $(PROG) $(OBJ) -lm
+
+ PURIFY_OPTIONS=-follow-child-processes=yes -always-use-cache-dir=yes
+ PURIFY=purify