summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-11-03 10:04:58 +1000
committerSam James <sam@gentoo.org>2023-11-25 03:59:23 +0000
commit6f6a90ef7be5806267af53e0360bc408515c4643 (patch)
tree5eaa144d1c5e16a15452fe6159d0094b132c83f4 /app-arch/zchunk
parentapp-arch/createrepo_c: drop 0.21.1, 1.0.0 (diff)
downloadgentoo-6f6a90ef7be5806267af53e0360bc408515c4643.tar.gz
gentoo-6f6a90ef7be5806267af53e0360bc408515c4643.tar.bz2
gentoo-6f6a90ef7be5806267af53e0360bc408515c4643.zip
app-arch/zchunk: add 1.3.2
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/zchunk')
-rw-r--r--app-arch/zchunk/Manifest1
-rw-r--r--app-arch/zchunk/zchunk-1.3.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-arch/zchunk/Manifest b/app-arch/zchunk/Manifest
index d498557c5ecd..5e3a484be5a3 100644
--- a/app-arch/zchunk/Manifest
+++ b/app-arch/zchunk/Manifest
@@ -1 +1,2 @@
DIST zchunk-1.3.1.tar.gz 1508699 BLAKE2B a0c6c277b8fd940602c6de680ee3418decdb0f83e3ea345f0c884f704bda67938539ec15a3b0fb1f5e498bb7fa1c420637091c752d8dea6094de3eb98503efb1 SHA512 5eec3ee084f3192291f5956dc797275986ebaa004df580be73de18ff22a781b6c5362bedc6263c9ae3569e5fa12cf5225d87aed7ec4ddfa6210f5c92763566e5
+DIST zchunk-1.3.2.tar.gz 1508683 BLAKE2B a8b866d28e3a0f5bf5fda3b44f5f1d0589c374dd700d8c64497d729758e35ed1215367ff8b1114e436a776a419f1aa329f429016981f11c19fd0896db3520811 SHA512 32f3167db747a494373c03941450e8b6b7eb6ad6a07633ccb9dbd3176ffb79073746bbdf3f132605ad51de23b3b20434d1580cf7cd72e0b658263bb32359f5bc
diff --git a/app-arch/zchunk/zchunk-1.3.2.ebuild b/app-arch/zchunk/zchunk-1.3.2.ebuild
new file mode 100644
index 000000000000..e89d8926554d
--- /dev/null
+++ b/app-arch/zchunk/zchunk-1.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="File format designed for highly efficient deltas with good compression"
+HOMEPAGE="https://github.com/zchunk/zchunk"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zchunk/zchunk.git"
+else
+ SRC_URI="https://github.com/zchunk/zchunk/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ app-arch/zstd:=
+ net-misc/curl
+ dev-libs/openssl:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}