summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-31 17:23:13 +0000
committerSam James <sam@gentoo.org>2024-01-31 17:24:35 +0000
commit6f799ac853270e11839d0e7e2cd52ee76dc106d5 (patch)
tree3bb421138216327461f3369c4a2ed48dbfef3770 /app-arch
parentnet-proxy/haproxy: Bump to 2.9.4 (diff)
downloadgentoo-6f799ac853270e11839d0e7e2cd52ee76dc106d5.tar.gz
gentoo-6f799ac853270e11839d0e7e2cd52ee76dc106d5.tar.bz2
gentoo-6f799ac853270e11839d0e7e2cd52ee76dc106d5.zip
app-arch/createrepo_c: add 1.0.3
Upstream commit d075bebc7c680c0e766c4417c2f2ff96b4ddb476 in 1.0.2 makes this mandatory. Closes: https://bugs.gentoo.org/918490 Closes: https://bugs.gentoo.org/923303 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/createrepo_c/Manifest1
-rw-r--r--app-arch/createrepo_c/createrepo_c-1.0.3.ebuild66
-rw-r--r--app-arch/createrepo_c/createrepo_c-9999.ebuild7
3 files changed, 70 insertions, 4 deletions
diff --git a/app-arch/createrepo_c/Manifest b/app-arch/createrepo_c/Manifest
index b36b5eb001a5..2c9a3570ee55 100644
--- a/app-arch/createrepo_c/Manifest
+++ b/app-arch/createrepo_c/Manifest
@@ -1 +1,2 @@
DIST createrepo_c-1.0.2.tar.gz 629680 BLAKE2B 441b4bb6973c67325403a0ab3a34cf475daddd41c7823a6634c576f6ab5ff0b9354d8941bbd67223b9fbd0c60a0cb81130b125d66d7eb7850abc818eeeffd437 SHA512 b4ceba2f0b558843bdc04be30a10ffb785eea0beb6e1f1efe7373b2a47c8aba554f1a881194c02d1b3980332912d92aa84fdda079324b60c2d57c55e43fa9eb6
+DIST createrepo_c-1.0.3.tar.gz 630527 BLAKE2B d7959f8f8dad6a35ff19355420f744722a7d5698beb6535c57ab1b61d223150220a89192a041f4258471f76b8c76aca0a9d068fc058e0555b3a1f652a510f5e9 SHA512 42877eb0216e90f7beff3ed17e061b72abc3edf818323265cb76a70efdc2aa847a773b0c3bdfba1ca299cbbe976a66106d0b49cf9a8a43db761579432d7ebaa5
diff --git a/app-arch/createrepo_c/createrepo_c-1.0.3.ebuild b/app-arch/createrepo_c/createrepo_c-1.0.3.ebuild
new file mode 100644
index 000000000000..afc050773235
--- /dev/null
+++ b/app-arch/createrepo_c/createrepo_c-1.0.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C implementation of createrepo"
+HOMEPAGE="https://github.com/rpm-software-management/createrepo_c"
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rpm-software-management/createrepo_c.git"
+else
+ SRC_URI="https://github.com/rpm-software-management/createrepo_c/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="legacy test zstd"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ app-arch/bzip2:=
+ app-arch/drpm
+ app-arch/rpm
+ app-arch/xz-utils
+ app-arch/zchunk
+ app-arch/zstd:=
+ >=dev-db/sqlite-3.6.18:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl:=
+ net-misc/curl
+ sys-apps/file
+ sys-libs/libmodulemd
+ sys-libs/zlib:=
+"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DRPM=ON
+ # As best I can tell, this enables distribution as a wheel. No need for this on gentoo!
+ -DENABLE_PYTHON=OFF
+ # Upstream enables some 'Legacy' stuff by default, let's put that behind a USE flag
+ -DENABLE_LEGACY_WEAKDEPS=$(usex legacy ON OFF)
+ -DWITH_LEGACY_HASHES=$(usex legacy ON OFF)
+ -DWITH_LIBMODULEMD=ON
+ -DWITH_ZCHUNK=ON
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ # Tests have a magic target!
+ use test && cmake_src_compile tests
+}
+
+src_test() {
+ "${S}"_build/tests/run_tests.sh || die "Failed to run C library tests"
+}
diff --git a/app-arch/createrepo_c/createrepo_c-9999.ebuild b/app-arch/createrepo_c/createrepo_c-9999.ebuild
index a9a502907e62..afc050773235 100644
--- a/app-arch/createrepo_c/createrepo_c-9999.ebuild
+++ b/app-arch/createrepo_c/createrepo_c-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,7 +27,8 @@ DEPEND="
app-arch/rpm
app-arch/xz-utils
app-arch/zchunk
- dev-db/sqlite:3
+ app-arch/zstd:=
+ >=dev-db/sqlite-3.6.18:3
dev-libs/glib:2
dev-libs/libxml2
dev-libs/openssl:=
@@ -35,7 +36,6 @@ DEPEND="
sys-apps/file
sys-libs/libmodulemd
sys-libs/zlib:=
- zstd? ( app-arch/zstd:= )
"
RDEPEND="${DEPEND}"
@@ -50,7 +50,6 @@ src_configure() {
-DWITH_LEGACY_HASHES=$(usex legacy ON OFF)
-DWITH_LIBMODULEMD=ON
-DWITH_ZCHUNK=ON
- -DWITH_ZSTD=$(usex zstd)
)
cmake_src_configure