summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-03-27 09:34:01 -0400
committerCraig Andrews <candrews@gentoo.org>2023-03-27 09:34:01 -0400
commit2e654e4635421975c2cd542b1c6e121eec72a385 (patch)
tree23a72001eb906b5162d2a877bb75619ac4efbb9a /app-backup/btrbk
parentnet-p2p/cpuminer-opt: drop 3.21.5 (diff)
downloadgentoo-2e654e4635421975c2cd542b1c6e121eec72a385.tar.gz
gentoo-2e654e4635421975c2cd542b1c6e121eec72a385.tar.bz2
gentoo-2e654e4635421975c2cd542b1c6e121eec72a385.zip
app-backup/btrbk: add 0.32.6
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'app-backup/btrbk')
-rw-r--r--app-backup/btrbk/Manifest1
-rw-r--r--app-backup/btrbk/btrbk-0.32.6.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-backup/btrbk/Manifest b/app-backup/btrbk/Manifest
index fb4632a4a545..11ac33b9ccec 100644
--- a/app-backup/btrbk/Manifest
+++ b/app-backup/btrbk/Manifest
@@ -1,2 +1,3 @@
DIST btrbk-0.31.2.tar.xz 107124 BLAKE2B a05ef8a665d50b0f9637b1bc7026f0ca0f8364377b4165dae09cd27790dc139aaea1096a54719d948adda5050f91580650bf58db70a086cfdd14b73559fad9f3 SHA512 f953fe1a231f7a28c2d98cf124e3d52cc6d0810e6cb1673b90f335e07cd7473d0302ec227361f902c40a36dab5c075c675d2ee0543a23c37cb1e4baaf74efea0
DIST btrbk-0.32.5.tar.xz 110840 BLAKE2B 036a2b5c31a308dbc1efc7a27211f89dfc07bcfcead49deb68a2e8313aec9539483ef3a91481f4ebaa9d2b4817b202ced1945a30ed7fc9b51f1336878b2f17d7 SHA512 6ff8df173656cbfdc1c4e74e84e031816fec73c2a42d1069fe5e77bf9eff1a3e27699a383ee58843f59619e6cbc0d66d13bf1b2a72524c58fdcd948ba62448fc
+DIST btrbk-0.32.6.tar.xz 111804 BLAKE2B f23e5f60e63bb1a9d5cc2f1339ac3e40a9cae5c0e3f626f1ad0e7396b8f9ebb00bce319835c9c708cdfe3c1cad3ef4e90985cb9c633be7091ffdbde93a10412c SHA512 5a21b3728aded1610ef9106d0460db12b07bbc6d62be199081baba92413b30ba0f7b4a77612d0bbb0910863be85f2c68eab3d02fabf1ea5a7f5fb22aeb1f7a38
diff --git a/app-backup/btrbk/btrbk-0.32.6.ebuild b/app-backup/btrbk/btrbk-0.32.6.ebuild
new file mode 100644
index 000000000000..751ed2dd6a2e
--- /dev/null
+++ b/app-backup/btrbk/btrbk-0.32.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/digint/btrbk.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
+HOMEPAGE="https://digint.ch/btrbk/"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+mbuffer +doc +lsbtr"
+
+DEPEND="doc? ( >=dev-ruby/asciidoctor-1.5.7 )"
+
+RDEPEND="dev-lang/perl
+ net-misc/openssh
+ mbuffer? ( >=sys-block/mbuffer-20180505 )
+ >=sys-fs/btrfs-progs-4.12"
+
+src_compile() {
+ emake clean
+ use doc && emake -C doc
+}
+src_install() {
+ local targets="install-bin install-etc install-share install-systemd"
+ use doc && targets="${targets} install-man install-doc"
+ use lsbtr && targets="${targets} install-bin-links"
+ emake \
+ DESTDIR="${D}" \
+ DOCDIR="/usr/share/doc/${PF}" \
+ SYSTEMDDIR="$(systemd_get_systemunitdir)" \
+ ${targets}
+}
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
+ upgrade_0_26_0_warning="1"
+ fi
+ if has_version "<${CATEGORY}/${PN}-0.27.0" ; then
+ upgrade_0_27_0_warning="1"
+ fi
+}
+pkg_postinst() {
+ if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
+ ewarn "If you are using raw targets, make sure to run the"
+ ewarn "\"raw_suffix2sidecar\" utility in each target directory."
+ fi
+ if [[ "${upgrade_0_27_0_warning}" == "1" ]]; then
+ ewarn 'Due to a bugfix in the scheduler [1] [2], previously preserved'
+ ewarn 'monthly/yearly backups could get deleted when upgrading to'
+ ewarn 'btrbk-0.27.0.'
+ ewarn ''
+ ewarn 'Before upgrading to btrbk-0.27.0, make sure to stop all cron jobs'
+ ewarn 'or systemd timers calling btrbk.'
+ ewarn ''
+ ewarn 'After upgrading, run "btrbk prune --dry-run --print-schedule" and'
+ ewarn 'check if any snapshots/backups would get deleted. If you want to'
+ ewarn 'forcibly preserve a snapshot/backup forever, rename it:'
+ ewarn ''
+ ewarn ' mv mysubvol.YYYYMMDD mysubvol.YYYYMMDD.keep_forever'
+ ewarn ''
+ ewarn 'Note that btrbk ignores subvolumes with unknown naming scheme, e.g.'
+ ewarn '(".keep_forever" suffix in the example above).'
+ ewarn ''
+ ewarn ' [1] https://github.com/digint/btrbk/issues/217'
+ ewarn ' [2] https://github.com/digint/btrbk/commit/719fb5f'
+ fi
+}