summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-08-30 11:46:35 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-08-30 11:47:57 +0200
commit1988d5456a4d174b5e34f331cc365310c676fdeb (patch)
tree7baa1c4b9328e68025335b0e71a1ff067b687255 /app-backup
parentsys-cluster/galera: add 26.4.20 (diff)
downloadgentoo-1988d5456a4d174b5e34f331cc365310c676fdeb.tar.gz
gentoo-1988d5456a4d174b5e34f331cc365310c676fdeb.tar.bz2
gentoo-1988d5456a4d174b5e34f331cc365310c676fdeb.zip
app-backup/borgmatic: add 1.8.14
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.8.14.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 40352b279987..59a8cdd514c4 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,2 +1,3 @@
DIST borgmatic-1.8.12.tar.gz 602369 BLAKE2B 79589e1510be9065d70b48ac5b8ce83a8d82776040cfe0ec833e7c9cbc33e4d285a2292870e2237902900ebb03204c6aafd702a2729b8860aec234429ec00921 SHA512 9cb91a4e7047da4effff69dfaea2358bd0d0897197d306775a3e9e260a2da6cc183c7675e02885fcd3d853c185171372371638b482b3e8b2f1bfcbcb2a14e4b7
DIST borgmatic-1.8.13.tar.gz 621942 BLAKE2B abea4779d6b8dc2e7885c4e5ff4e6e4a472ecdba8b248f28b137ab25df5c12ce31e71489485966a0df27c8ff388476049ed8f58fcd53d16d09f01e9fa215ac0e SHA512 0057ba195c493c47ecb4eaaca1987b68c332632ebe5015ac20cd5f59f3f8f8b00a06749d828f003866986b3f70c3794a945577f4f49bf775153aa0f75fdfcf49
+DIST borgmatic-1.8.14.tar.gz 623966 BLAKE2B fd52bc5be4f63e1207a0bedcf654af075082d31af76ddc65ea30a3259f1ec093c826612e114fd9f9fa46668f80eed3b2b6a88262fbb9e4db49c36ba31efa70c5 SHA512 74daecbf02f957b21121dff073c2e114c87b1afdf6b3408b8fc2bf465102425cca60e4bdc8bc8d0e2d0a9c20b1f514eb7c9a2e136e71cb61969e07a38841235a
diff --git a/app-backup/borgmatic/borgmatic-1.8.14.ebuild b/app-backup/borgmatic/borgmatic-1.8.14.ebuild
new file mode 100644
index 000000000000..de16568a999b
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.8.14.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="apprise"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ ')
+ apprise? ( $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ ') )"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.13-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.8.0; then
+ ewarn "Please be warned that ${PN}-1.8.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.8.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+}