summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2025-01-12 08:58:45 +0000
committerYixun Lan <dlan@gentoo.org>2025-01-12 08:59:23 +0000
commit74d268c45b78704fe7c950f035fc83eb2e6b0bdc (patch)
tree9d7b5418895fea5f547d0bfc9992f690be71633d /app-backup
parentapp-backup/snapper: add 0.12.1 (diff)
downloadgentoo-74d268c45b78704fe7c950f035fc83eb2e6b0bdc.tar.gz
gentoo-74d268c45b78704fe7c950f035fc83eb2e6b0bdc.tar.bz2
gentoo-74d268c45b78704fe7c950f035fc83eb2e6b0bdc.zip
app-backup/snapper: drop 0.11.0, 0.11.2
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/snapper/Manifest2
-rw-r--r--app-backup/snapper/snapper-0.11.0.ebuild90
-rw-r--r--app-backup/snapper/snapper-0.11.2.ebuild90
3 files changed, 0 insertions, 182 deletions
diff --git a/app-backup/snapper/Manifest b/app-backup/snapper/Manifest
index d1c9bd47cdb4..3c79f14b5846 100644
--- a/app-backup/snapper/Manifest
+++ b/app-backup/snapper/Manifest
@@ -1,4 +1,2 @@
-DIST snapper-0.11.0.tar.gz 445685 BLAKE2B 301e6d745d8d6d7acc6ca0c9fc431a0e46700aabd9882785bb2be38152693f9dbe897f85f6ad724c9529a0754b6146b53dda0a24141b386e59e7737855bc5da2 SHA512 fe86be4ceb1439b5be3fa61f5bc037bc51a5fe47451d0698851f83e2783d6c245ef8d40a33f79b03e8d1d8b63433743c35938ad7dca0747e0e1f650a5a766c40
-DIST snapper-0.11.2.tar.gz 451240 BLAKE2B 08afbdb7808d16555ca476e2a4336b9ee7da7e368a8bba1f131b7413d60ce0c61cb8e6ebc14cfebf5184d426b39c2d042f450494dcd65de30627870407ec8652 SHA512 b418ff91c6ba655edebd600691e2a7c0bc277eb6e327d5c57d0e5b2e008ee859e82a7dc49f2b25003001f0e6e5fc69e611c843231160bbb4626867cfc4cf95e2
DIST snapper-0.12.0.tar.gz 530406 BLAKE2B 575a1cf251c789c38f3cce623e6074dde4d195914f7b391f2a0d4f588e5ff90b47c56b1897cb9a6d6a7789ed6d5e3676cb9ac3719fa33e9dabdc26227ea5b1e2 SHA512 f022ce76633e3d64e2c3c825a9113b2f77d0e672188b4af644e37388cb3636b4878131917a734aab3b74e744b5e437d53657744df37ec53671442cef4e3bb873
DIST snapper-0.12.1.tar.gz 536687 BLAKE2B 1fbc8a99848016974db82c3993cd22fe402fba49ab128919e291704f602447c3d5b63f9681eff038e4bfbf89da8e5516516b22e8d93ca637ecca89c33ce89df6 SHA512 be7e227c7b7935d9be25ada77b758e654102881b8b7886fca312a9be990fbf701db774bfcccde4a05b9e1c0b31aa7f757a7a94a254c49fd54ba7a1395b3a6716
diff --git a/app-backup/snapper/snapper-0.11.0.ebuild b/app-backup/snapper/snapper-0.11.0.ebuild
deleted file mode 100644
index 011eb5479f3e..000000000000
--- a/app-backup/snapper/snapper-0.11.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools systemd
-
-DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
-HOMEPAGE="http://snapper.io/"
-SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv x86"
-IUSE="lvm pam test systemd xattr"
-RESTRICT="test"
-
-BDEPEND="app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- sys-devel/gettext
- virtual/pkgconfig"
-
-RDEPEND="dev-libs/boost:=
- dev-libs/json-c:=
- dev-libs/libxml2
- dev-libs/icu:=
- sys-apps/acl
- sys-apps/dbus
- sys-apps/util-linux
- >=sys-fs/btrfs-progs-3.17.1
- sys-libs/zlib
- virtual/libintl
- lvm? ( sys-fs/lvm2 )
- pam? ( sys-libs/pam )
- xattr? ( sys-apps/attr )"
-
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-cron-confd.patch
- "${FILESDIR}"/${PN}-0.10.1-testsuite.patch
-)
-
-src_prepare() {
- default
-
- sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
- -i data/Makefile.* \
- || die "Failed to fix systemd services and timers installation path"
- eautoreconf
-}
-
-src_configure() {
- # ext4 code does not work anymore
- # snapper does not build without btrfs
- local myeconfargs=(
- --disable-silent-rules
- --with-conf="/etc/conf.d"
- --enable-zypp
- --enable-rollback
- --enable-btrfs-quota
- --disable-ext4
- --enable-btrfs
- --enable-doc
- $(use_enable lvm)
- $(use_enable pam)
- $(use_enable test tests)
- $(use_enable systemd)
- $(use_enable xattr xattrs)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- # Existing configuration file required to function
- keepdir /etc/snapper/configs
- newconfd data/sysconfig.snapper snapper
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- elog "In order to use Snapper, you need to set up"
- elog "at least one config first. To do this, run:"
- elog "snapper create-config <subvolume>"
- elog "For more information, see man (8) snapper or"
- elog "http://snapper.io/documentation.html and"
- elog "https://wiki.gentoo.org/wiki/Snapper"
-}
diff --git a/app-backup/snapper/snapper-0.11.2.ebuild b/app-backup/snapper/snapper-0.11.2.ebuild
deleted file mode 100644
index 92c569f5b215..000000000000
--- a/app-backup/snapper/snapper-0.11.2.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools systemd
-
-DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
-HOMEPAGE="http://snapper.io/"
-SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
-IUSE="lvm pam test systemd xattr"
-RESTRICT="test"
-
-BDEPEND="app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- sys-devel/gettext
- virtual/pkgconfig"
-
-RDEPEND="dev-libs/boost:=
- dev-libs/json-c:=
- dev-libs/libxml2
- dev-libs/icu:=
- sys-apps/acl
- sys-apps/dbus
- sys-apps/util-linux
- >=sys-fs/btrfs-progs-3.17.1
- sys-libs/zlib
- virtual/libintl
- lvm? ( sys-fs/lvm2 )
- pam? ( sys-libs/pam )
- xattr? ( sys-apps/attr )"
-
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.11.0-cron-confd.patch
- "${FILESDIR}"/${PN}-0.10.1-testsuite.patch
-)
-
-src_prepare() {
- default
-
- sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
- -i data/Makefile.* \
- || die "Failed to fix systemd services and timers installation path"
- eautoreconf
-}
-
-src_configure() {
- # ext4 code does not work anymore
- # snapper does not build without btrfs
- local myeconfargs=(
- --disable-silent-rules
- --with-conf="/etc/conf.d"
- --enable-zypp
- --enable-rollback
- --enable-btrfs-quota
- --disable-ext4
- --enable-btrfs
- --enable-doc
- $(use_enable lvm)
- $(use_enable pam)
- $(use_enable test tests)
- $(use_enable systemd)
- $(use_enable xattr xattrs)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- # Existing configuration file required to function
- keepdir /etc/snapper/configs
- newconfd data/sysconfig.snapper snapper
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- elog "In order to use Snapper, you need to set up"
- elog "at least one config first. To do this, run:"
- elog "snapper create-config <subvolume>"
- elog "For more information, see man (8) snapper or"
- elog "http://snapper.io/documentation.html and"
- elog "https://wiki.gentoo.org/wiki/Snapper"
-}