summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-03 04:35:03 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-03 04:35:03 -0400
commit6f7954fe90f7e1ed85533a614b89726fad18fd68 (patch)
tree6e54d7de50aed35c8303fd89c8c1d616ddc4ed42 /app-benchmarks/siege/siege-3.1.0.ebuild
parentapp-benchmarks/httperf: add libressl support (diff)
downloadgentoo-6f7954fe90f7e1ed85533a614b89726fad18fd68.tar.gz
gentoo-6f7954fe90f7e1ed85533a614b89726fad18fd68.tar.bz2
gentoo-6f7954fe90f7e1ed85533a614b89726fad18fd68.zip
app-benchmarks/siege: add libressl support
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-benchmarks/siege/siege-3.1.0.ebuild')
-rw-r--r--app-benchmarks/siege/siege-3.1.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/app-benchmarks/siege/siege-3.1.0.ebuild b/app-benchmarks/siege/siege-3.1.0.ebuild
deleted file mode 100644
index f3cdef513ace..000000000000
--- a/app-benchmarks/siege/siege-3.1.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-#WANT_AUTOMAKE=1.9
-
-inherit eutils bash-completion-r1 libtool autotools
-
-DESCRIPTION="A HTTP regression testing and benchmarking utility"
-HOMEPAGE="https://www.joedog.org/siege-home/"
-SRC_URI="http://download.joedog.org/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~x64-macos"
-SLOT="0"
-IUSE="ssl"
-
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6d:= )"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_prepare() {
- # bundled macros break recent libtool
- sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
- rm *.m4 || die "failed to remove bundled macros"
- eautoreconf
-}
-
-src_configure() {
- local myconf
- use ssl && myconf="--with-ssl=${EPREFIX}/usr" || myconf="--without-ssl"
- econf ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
- doc/siegerc doc/urls.txt
-
- newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
-}
-
-pkg_postinst() {
- echo
- elog "An example ~/.siegerc file has been installed in"
- elog "${EPREFIX}/usr/share/doc/${PF}/"
-}