summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2022-05-14 00:48:47 +1000
committerSam James <sam@gentoo.org>2022-05-13 20:12:39 +0000
commit85d1acdb1f65d2b341fab003027954845bc67c9c (patch)
tree4cfc9401c4e9a5701c75a34bc057610b88b1bec1 /app-containers/crun/crun-1.3.ebuild
parentapp-containers/crun: add 1.4.5 (diff)
downloadgentoo-85d1acdb1f65d2b341fab003027954845bc67c9c.tar.gz
gentoo-85d1acdb1f65d2b341fab003027954845bc67c9c.tar.bz2
gentoo-85d1acdb1f65d2b341fab003027954845bc67c9c.zip
app-containers/crun: drop 1.3, 1.4.2
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Closes: https://github.com/gentoo/gentoo/pull/25470 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-containers/crun/crun-1.3.ebuild')
-rw-r--r--app-containers/crun/crun-1.3.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/app-containers/crun/crun-1.3.ebuild b/app-containers/crun/crun-1.3.ebuild
deleted file mode 100644
index 0ad076a2251c..000000000000
--- a/app-containers/crun/crun-1.3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit python-any-r1
-
-DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
-HOMEPAGE="https://github.com/containers/crun"
-SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64"
-IUSE="+bpf +caps criu +seccomp systemd static-libs"
-
-DEPEND="
- dev-libs/yajl:=
- sys-kernel/linux-headers
- caps? ( sys-libs/libcap )
- criu? ( >=sys-process/criu-3.15 )
- seccomp? ( sys-libs/libseccomp )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the privileges
-# required to create linux "containers".
-RESTRICT="test"
-
-src_configure() {
- local myeconfargs=(
- $(use_enable bpf)
- $(use_enable caps)
- $(use_enable criu)
- $(use_enable seccomp)
- $(use_enable systemd)
- $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake -C libocispec
- emake crun
-}
-
-src_install() {
- emake "DESTDIR=${D}" install-exec
- doman crun.1
- einstalldocs
-}