summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-10-11 15:42:37 -0700
committerZac Medico <zmedico@gentoo.org>2024-10-11 15:47:21 -0700
commit7257745471693c4040eff09bdbe8f49616aba50c (patch)
tree99780def47d83b58b0183779ac826444e7640c2e /app-containers
parentapp-containers/containers-storage: add 1.55.0 (diff)
downloadgentoo-7257745471693c4040eff09bdbe8f49616aba50c.tar.gz
gentoo-7257745471693c4040eff09bdbe8f49616aba50c.tar.bz2
gentoo-7257745471693c4040eff09bdbe8f49616aba50c.zip
app-containers/containers-image: add 5.32.2
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/containers-image/Manifest1
-rw-r--r--app-containers/containers-image/containers-image-5.32.2.ebuild35
-rw-r--r--app-containers/containers-image/containers-image-9999.ebuild3
3 files changed, 36 insertions, 3 deletions
diff --git a/app-containers/containers-image/Manifest b/app-containers/containers-image/Manifest
index 1382b8858816..f1adcbdab4a1 100644
--- a/app-containers/containers-image/Manifest
+++ b/app-containers/containers-image/Manifest
@@ -1,2 +1,3 @@
DIST containers-image-5.29.2.tar.gz 707618 BLAKE2B f1556cbb26ceedd74a338355caf8b557c43286726f4be63544cebc9a8f4b92be78d7a0cddbedaba7352d13e9fc399f62ee114caba6c8b1ecc334dab1379e523b SHA512 f3f6e09670dc393067992a78303f01e2584dabe79ba156973a50d7a460c011e5a27d0ccdf0ff6b399099a9a3a4c57f3badf24fb5d0704efd645ab7196a544d8f
DIST containers-image-5.30.0.tar.gz 719070 BLAKE2B 5952ab703b6df793f326dd4fc82f50c5f672e2b9d142e0bc706014092420e3563599d9f1c1f65f743e1a8144b91f92b2326d7bf4c3024b5efb466d777a8ad613 SHA512 89cd0d482bb5d70037ff51413b7abca01d36bc7f39e9dc130c78462e501dae32193137a367d81532afd216a7432e127728147e6e839d5d99eeb6b6680f31d4dc
+DIST containers-image-5.32.2.tar.gz 735422 BLAKE2B a0585c877b4679226d1760bf873ceeb5cba7f5177ab83fa6f8a161b1f3958f3d660445556b13b4221712c241cee94429cabdb1fd4186d4dc6edba7b032fce2bc SHA512 7498f9e446b2c205b033703641f7cfcb6c8bd8f097b12ef3f734c94772d63fc7b9b40a6700d53d93919d2c34772f079aa3cb7d9f9e5a130b6587f4fe2a558df6
diff --git a/app-containers/containers-image/containers-image-5.32.2.ebuild b/app-containers/containers-image/containers-image-5.32.2.ebuild
new file mode 100644
index 000000000000..2b3c1bcb8666
--- /dev/null
+++ b/app-containers/containers-image/containers-image-5.32.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Default config and docs related to Containers' images"
+HOMEPAGE="https://github.com/containers/image"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/image.git"
+else
+ SRC_URI="https://github.com/containers/image/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64 ~arm64 ~loong ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+# https://github.com/gentoo/gentoo/pull/35012#discussion_r1473740969
+RESTRICT='test'
+BDEPEND=">=dev-go/go-md2man-2.0.3"
+RDEPEND="!<=app-containers/containers-common-0.57.0"
+
+src_compile() {
+ emake docs
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ insinto /etc/containers
+ doins registries.conf
+}
diff --git a/app-containers/containers-image/containers-image-9999.ebuild b/app-containers/containers-image/containers-image-9999.ebuild
index 40770f7a7d7d..2b3c1bcb8666 100644
--- a/app-containers/containers-image/containers-image-9999.ebuild
+++ b/app-containers/containers-image/containers-image-9999.ebuild
@@ -22,9 +22,6 @@ SLOT="0"
RESTRICT='test'
BDEPEND=">=dev-go/go-md2man-2.0.3"
RDEPEND="!<=app-containers/containers-common-0.57.0"
-PATCHES=(
- "${FILESDIR}"/fix-warnings.patch
-)
src_compile() {
emake docs