summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-05-12 23:11:42 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-05-12 23:20:18 +0200
commitf39ae000ce0d7b5afa7fe5f8f47974c187b5c1a2 (patch)
tree527f00e518c7084d82ac5760525c79fba9c82eb8 /app-crypt/acme-sh
parentdev-db/mysqltuner: drop 1.7.21-r1 (diff)
downloadgentoo-f39ae000ce0d7b5afa7fe5f8f47974c187b5c1a2.tar.gz
gentoo-f39ae000ce0d7b5afa7fe5f8f47974c187b5c1a2.tar.bz2
gentoo-f39ae000ce0d7b5afa7fe5f8f47974c187b5c1a2.zip
app-crypt/acme-sh: add 3.0.4
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt/acme-sh')
-rw-r--r--app-crypt/acme-sh/Manifest1
-rw-r--r--app-crypt/acme-sh/acme-sh-3.0.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/acme-sh/Manifest b/app-crypt/acme-sh/Manifest
index 4446a5f66127..4dcc2d7c974f 100644
--- a/app-crypt/acme-sh/Manifest
+++ b/app-crypt/acme-sh/Manifest
@@ -1 +1,2 @@
DIST acme.sh-3.0.3.tar.gz 253111 BLAKE2B 43b97b033e5e16412e8a958966077ba6b26c49b17206cda5af848b7f9fbf8a8f8bc406b63a13f792dfa93ff7b0759da03a0f599c43f92d25587b582feb59a3cf SHA512 b26f20422a3b40d6c1acbdd52d41124962975313f4187cf918746ad9dc047600a92e529cd1e66ede5b456e253522920b574cb614f455dd73aac707a18f34ad35
+DIST acme.sh-3.0.4.tar.gz 253157 BLAKE2B b1bde1ca31ef34c264f5045dd36220b3fd04230c59f7e65a9623681377dbde161ed3b92d86bd3e6f5a115d8847b1c2019bf984194f2901b52eb65abefad8bf81 SHA512 919987ac026366d245fa2730edf1212deafb051129811f35b482a30af9b0034a802baa218a35048e030795127cfeae03b4c3d4f12e580cd82edbacdd72e588e7
diff --git a/app-crypt/acme-sh/acme-sh-3.0.4.ebuild b/app-crypt/acme-sh/acme-sh-3.0.4.ebuild
new file mode 100644
index 000000000000..388ce2e32f48
--- /dev/null
+++ b/app-crypt/acme-sh/acme-sh-3.0.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+inherit optfeature
+
+DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
+HOMEPAGE="https://github.com/acmesh-official/acme.sh"
+SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:0
+ net-misc/curl
+ net-misc/socat
+"
+
+src_install() {
+ newdoc deploy/README.md README-deploy.md
+ newdoc dnsapi/README.md README-dnsapi.md
+ rm {deploy,dnsapi}/README.md || die
+ einstalldocs
+
+ exeinto /usr/share/acme.sh
+ doexe acme.sh
+
+ insinto /usr/share/acme.sh
+ doins -r deploy dnsapi notify
+
+ keepdir /etc/acme-sh
+ doenvd "${FILESDIR}"/99acme-sh
+
+ insinto /etc/bash/bashrc.d
+ doins "${FILESDIR}"/acme.sh
+
+ dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
+}
+
+pkg_postinst() {
+ optfeature_header "For webserver mode, install a supported web server:"
+ optfeature "using apache2 webserver mode" www-servers/apache
+ optfeature "using nginx webserver mode" www-servers/nginx
+}