summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-08-31 17:33:15 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-08-31 17:33:15 +0200
commit916a07272b328c306a435ef04467e33dbe9c1dcd (patch)
treea8f531a5be843c34b1ff3d80e25ab4520d27b4b1 /app-crypt/aescrypt/files
parentapp-benchmarks/siege: fix variable order (diff)
downloadgentoo-916a07272b328c306a435ef04467e33dbe9c1dcd.tar.gz
gentoo-916a07272b328c306a435ef04467e33dbe9c1dcd.tar.bz2
gentoo-916a07272b328c306a435ef04467e33dbe9c1dcd.zip
app-crypt/aescrypt: drop 3.14
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-crypt/aescrypt/files')
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.14-iconv.patch40
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch20
2 files changed, 0 insertions, 60 deletions
diff --git a/app-crypt/aescrypt/files/aescrypt-3.14-iconv.patch b/app-crypt/aescrypt/files/aescrypt-3.14-iconv.patch
deleted file mode 100644
index 8232f80aebbc..000000000000
--- a/app-crypt/aescrypt/files/aescrypt-3.14-iconv.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 337cc9367a3cb4450eee245c6ceb615d0f05499d Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Sat, 2 Feb 2013 01:18:08 +0200
-Subject: [PATCH 2/2] build: support disable iconv for static build
-
-Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
----
- password.c | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
-diff --git a/password.c b/password.c
-index 9a2c1f8..dee79da 100644
---- a/src/password.c
-+++ b/src/password.c
-@@ -232,6 +232,15 @@ int passwd_to_utf16(unsigned char *in_passwd,
- size_t ic_inbytesleft,
- ic_outbytesleft;
-
-+#ifdef DISABLE_ICONV
-+ /* support only latin */
-+ int i;
-+ for (i=0;i<length+1;i++) {
-+ out_passwd[i*2] = in_passwd[i];
-+ out_passwd[i*2+1] = 0;
-+ }
-+ return length*2;
-+#else
- /* Max length is specified in character, but this function deals
- * with bytes. So, multiply by two since we are going to create a
- * UTF-16 string.
-@@ -273,5 +282,6 @@ int passwd_to_utf16(unsigned char *in_passwd,
- }
- iconv_close(condesc);
- return (max_length - ic_outbytesleft);
-+#endif
- }
-
---
-1.7.12.4
-
diff --git a/app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch b/app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch
deleted file mode 100644
index 757f0e4e7fcb..000000000000
--- a/app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -Naru a/src/Makefile b/src/Makefile
---- a/src/Makefile 2021-07-14 09:25:15.509797042 +0200
-+++ b/src/Makefile 2021-07-14 09:25:46.689797121 +0200
-@@ -27,13 +27,13 @@
- all: aescrypt aescrypt_keygen
-
- aescrypt: $(AESCRYPT_OBJS)
-- $(CC) $(CFLAGS) $(LIBS) -o $@ $(AESCRYPT_OBJS)
-+ $(CC) $(CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $(AESCRYPT_OBJS)
-
- aescrypt_keygen: $(KEYGEN_OBJS)
-- $(CC) $(CFLAGS) $(LIBS) -o $@ $(KEYGEN_OBJS)
-+ $(CC) $(CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $(KEYGEN_OBJS)
-
- %.o: %.c %.h
-- $(CC) $(CFLAGS) -c $*.c
-+ $(CC) $(CFLAGS) $(LDFLAGS) -c $*.c
-
- install: aescrypt
- install -o root -g root -m 755 aescrypt /usr/bin