summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/osslsigncode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/osslsigncode')
-rw-r--r--app-crypt/osslsigncode/Manifest1
-rw-r--r--app-crypt/osslsigncode/metadata.xml11
-rw-r--r--app-crypt/osslsigncode/osslsigncode-1.4.ebuild23
3 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/osslsigncode/Manifest b/app-crypt/osslsigncode/Manifest
new file mode 100644
index 000000000000..e6a197de88cb
--- /dev/null
+++ b/app-crypt/osslsigncode/Manifest
@@ -0,0 +1 @@
+DIST osslsigncode-1.4.tar.gz 96512 SHA256 721eddade1571fcde54e7f5c21f961dacb990c19f9bdb05c4a7aaeb269979069 SHA512 89f82b5cbab5952b7bb0b1a3ea230db0c38d171924e5150e9cd157158e52d312cc10093ac719265d03a097f995bd3a438fe874c50263659859c625482ef0239f WHIRLPOOL a3fadd7e9e4e8bb295d33b6e7696fe5e7ba32f252656fef3faa59bcd86ddf6ceec2e5532cc136e078af6eaf74c169edfaa18635151e993061f071b7cdb0807c6
diff --git a/app-crypt/osslsigncode/metadata.xml b/app-crypt/osslsigncode/metadata.xml
new file mode 100644
index 000000000000..f8958dea6d9d
--- /dev/null
+++ b/app-crypt/osslsigncode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ <description>do whatever</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">osslsigncode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/osslsigncode/osslsigncode-1.4.ebuild b/app-crypt/osslsigncode/osslsigncode-1.4.ebuild
new file mode 100644
index 000000000000..40c7df0e2359
--- /dev/null
+++ b/app-crypt/osslsigncode/osslsigncode-1.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Platform-independent tool for Authenticode signing of EXE/CAB files"
+HOMEPAGE="https://sourceforge.net/projects/osslsigncode"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl"
+
+RDEPEND="dev-libs/openssl
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_with curl)
+}