summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /app-crypt
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/nitrocli/nitrocli-0.4.1-r1.ebuild (renamed from app-crypt/nitrocli/nitrocli-0.4.1.ebuild)126
-rw-r--r--app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild (renamed from app-crypt/rpm-sequoia/rpm-sequoia-1.6.0.ebuild)12
-rw-r--r--app-crypt/rpm-sequoia/rpm-sequoia-1.7.0-r1.ebuild (renamed from app-crypt/rpm-sequoia/rpm-sequoia-1.7.0.ebuild)12
-rw-r--r--app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.0-r1.ebuild (renamed from app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.0.ebuild)12
-rw-r--r--app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.1-r1.ebuild (renamed from app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.1.ebuild)12
-rw-r--r--app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.8.0-r1.ebuild (renamed from app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.8.0.ebuild)12
-rw-r--r--app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.9.0-r1.ebuild (renamed from app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.9.0.ebuild)12
-rw-r--r--app-crypt/sequoia-sq/sequoia-sq-0.35.0-r1.ebuild (renamed from app-crypt/sequoia-sq/sequoia-sq-0.35.0.ebuild)8
-rw-r--r--app-crypt/sequoia-sq/sequoia-sq-0.36.0-r1.ebuild (renamed from app-crypt/sequoia-sq/sequoia-sq-0.36.0.ebuild)8
-rw-r--r--app-crypt/sequoia-sq/sequoia-sq-0.37.0-r1.ebuild (renamed from app-crypt/sequoia-sq/sequoia-sq-0.37.0.ebuild)8
-rw-r--r--app-crypt/sequoia-sqv/sequoia-sqv-1.2.1-r1.ebuild (renamed from app-crypt/sequoia-sqv/sequoia-sqv-1.2.1.ebuild)8
11 files changed, 142 insertions, 88 deletions
diff --git a/app-crypt/nitrocli/nitrocli-0.4.1.ebuild b/app-crypt/nitrocli/nitrocli-0.4.1-r1.ebuild
index f41366c4a624..1c560a2e5176 100644
--- a/app-crypt/nitrocli/nitrocli-0.4.1.ebuild
+++ b/app-crypt/nitrocli/nitrocli-0.4.1-r1.ebuild
@@ -4,75 +4,75 @@
EAPI=8
CRATES="
-aho-corasick-0.7.18
-anyhow-1.0.40
-autocfg-1.0.1
-base32-0.4.0
-bitflags-1.2.1
-cc-1.0.67
-cfg-if-1.0.0
-clap-2.33.3
-directories-3.0.2
-dirs-sys-0.3.6
-envy-0.4.2
-getrandom-0.1.16
-getrandom-0.2.2
-heck-0.3.2
-lazy_static-1.4.0
-libc-0.2.146
-log-0.4.14
-memchr-2.4.0
-merge-0.1.0
-merge_derive-0.1.0
-nitrocli-0.4.1
-nitrokey-0.9.0
-nitrokey-sys-3.6.0
-nitrokey-test-0.5.0
-nitrokey-test-state-0.1.0
-num-traits-0.2.14
-numtoa-0.1.0
-ppv-lite86-0.2.10
-proc-macro-error-1.0.4
-proc-macro-error-attr-1.0.4
-proc-macro2-1.0.26
-progressing-3.0.2
-quote-1.0.9
-rand-0.8.3
-rand_chacha-0.3.0
-rand_core-0.5.1
-rand_core-0.6.2
-rand_hc-0.3.0
-redox_syscall-0.2.8
-redox_termios-0.1.2
-redox_users-0.4.0
-regex-1.5.4
-regex-syntax-0.6.25
-remove_dir_all-0.5.3
-serde-1.0.125
-serde_derive-1.0.125
-structopt-0.3.21
-structopt-derive-0.4.14
-syn-1.0.72
-tempfile-3.2.0
-termion-1.5.6
-textwrap-0.11.0
-toml-0.5.8
-unicode-segmentation-1.7.1
-unicode-width-0.1.8
-unicode-xid-0.2.2
-version_check-0.9.3
-wasi-0.9.0+wasi-snapshot-preview1
-wasi-0.10.2+wasi-snapshot-preview1
-winapi-0.3.9
-winapi-i686-pc-windows-gnu-0.4.0
-winapi-x86_64-pc-windows-gnu-0.4.0
+ aho-corasick@0.7.18
+ anyhow@1.0.40
+ autocfg@1.0.1
+ base32@0.4.0
+ bitflags@1.2.1
+ cc@1.0.67
+ cfg-if@1.0.0
+ clap@2.33.3
+ directories@3.0.2
+ dirs-sys@0.3.6
+ envy@0.4.2
+ getrandom@0.1.16
+ getrandom@0.2.2
+ heck@0.3.2
+ lazy_static@1.4.0
+ libc@0.2.146
+ log@0.4.14
+ memchr@2.4.0
+ merge@0.1.0
+ merge_derive@0.1.0
+ nitrocli@0.4.1
+ nitrokey@0.9.0
+ nitrokey-sys@3.6.0
+ nitrokey-test@0.5.0
+ nitrokey-test-state@0.1.0
+ num-traits@0.2.14
+ numtoa@0.1.0
+ ppv-lite86@0.2.10
+ proc-macro-error@1.0.4
+ proc-macro-error-attr@1.0.4
+ proc-macro2@1.0.26
+ progressing@3.0.2
+ quote@1.0.9
+ rand@0.8.3
+ rand_chacha@0.3.0
+ rand_core@0.5.1
+ rand_core@0.6.2
+ rand_hc@0.3.0
+ redox_syscall@0.2.8
+ redox_termios@0.1.2
+ redox_users@0.4.0
+ regex@1.5.4
+ regex-syntax@0.6.25
+ remove_dir_all@0.5.3
+ serde@1.0.125
+ serde_derive@1.0.125
+ structopt@0.3.21
+ structopt-derive@0.4.14
+ syn@1.0.72
+ tempfile@3.2.0
+ termion@1.5.6
+ textwrap@0.11.0
+ toml@0.5.8
+ unicode-segmentation@1.7.1
+ unicode-width@0.1.8
+ unicode-xid@0.2.2
+ version_check@0.9.3
+ wasi@0.9.0+wasi-snapshot-preview1
+ wasi@0.10.2+wasi-snapshot-preview1
+ winapi@0.3.9
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-x86_64-pc-windows-gnu@0.4.0
"
inherit bash-completion-r1 cargo
DESCRIPTION="A command line tool for interacting with Nitrokey devices"
HOMEPAGE="https://github.com/d-e-s-o/nitrocli"
-SRC_URI="$(cargo_crate_uris)"
+SRC_URI="${CARGO_CRATE_URIS}"
LICENSE="Apache-2.0 BSD-2 CC0-1.0 GPL-3+ LGPL-3 MIT"
SLOT="0"
diff --git a/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0.ebuild b/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild
index da34f4210ca1..f4f0fd4e2697 100644
--- a/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0.ebuild
+++ b/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild
@@ -235,9 +235,10 @@ CRATES="
zeroize_derive@1.4.2
"
-LLVM_MAX_SLOT=17
+LLVM_COMPAT=( 17 )
+RUST_NEEDS_LLVM=1
-inherit cargo llvm
+inherit llvm-r1 cargo
DESCRIPTION="Implementation of the RPM PGP interface using Sequoia"
HOMEPAGE="https://sequoia-pgp.org/ https://github.com/rpm-software-management/rpm-sequoia"
@@ -265,11 +266,16 @@ RDEPEND="${DEPEND}"
# Clang is required for bindgen
BDEPEND="
virtual/pkgconfig
- nettle? ( <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)) )
+ nettle? ( $(llvm_gen_dep 'sys-devel/clang:${LLVM_SLOT}') )
"
QA_FLAGS_IGNORED="usr/lib.*/librpm_sequoia.so.1"
+pkg_setup() {
+ llvm_r1_pkg_setup
+ rust_pkg_setup
+}
+
llvm_check_deps() {
if use nettle; then
has_version -b "sys-devel/clang:${LLVM_SLOT}"
diff --git a/app-crypt/rpm-sequoia/rpm-sequoia-1.7.0.ebuild b/app-crypt/rpm-sequoia/rpm-sequoia-1.7.0-r1.ebuild
index 082e1f09d371..9f361d92c6c6 100644
--- a/app-crypt/rpm-sequoia/rpm-sequoia-1.7.0.ebuild
+++ b/app-crypt/rpm-sequoia/rpm-sequoia-1.7.0-r1.ebuild
@@ -248,9 +248,11 @@ CRATES="
zerovec@0.10.4
"
-LLVM_COMPAT=( {17..18} )
+LLVM_COMPAT=( 17 18 )
+RUST_MIN_VER="1.74.1"
+RUST_NEEDS_LLVM=1
-inherit cargo llvm-r1
+inherit llvm-r1 cargo
DESCRIPTION="Implementation of the RPM PGP interface using Sequoia"
HOMEPAGE="https://sequoia-pgp.org/ https://github.com/rpm-software-management/rpm-sequoia"
@@ -282,12 +284,16 @@ RDEPEND="${DEPEND}"
# Clang is required for bindgen
BDEPEND="
virtual/pkgconfig
- >=virtual/rust-1.73
nettle? ( $(llvm_gen_dep 'sys-devel/clang:${LLVM_SLOT}') )
"
QA_FLAGS_IGNORED="usr/lib.*/librpm_sequoia.so.1"
+pkg_setup() {
+ llvm_r1_pkg_setup
+ rust_pkg_setup
+}
+
src_configure() {
local myfeatures=(
$(usev nettle crypto-nettle)
diff --git a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.0.ebuild b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.0-r1.ebuild
index 48f2892554d8..280dbafde49f 100644
--- a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.0.ebuild
+++ b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.0-r1.ebuild
@@ -394,8 +394,10 @@ CRATES="
zerovec@0.10.2
"
-LLVM_COMPAT=( {17..18} )
-inherit cargo llvm-r1 xdg-utils
+LLVM_COMPAT=( 17 18 )
+RUST_NEEDS_LLVM=1
+
+inherit llvm-r1 cargo xdg-utils
DESCRIPTION="Sequoia's reimplementation of the GnuPG interface"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-chameleon-gnupg/"
@@ -429,11 +431,15 @@ BDEPEND="
$(llvm_gen_dep '
sys-devel/clang:${LLVM_SLOT}
')
- >=virtual/rust-1.70
"
QA_FLAGS_IGNORED="usr/bin/gpg-sq usr/bin/gpgv-sq"
+pkg_setup() {
+ llvm_r1_pkg_setup
+ rust_pkg_setup
+}
+
src_test() {
local -x GNUPGHOME="${T}"/.gnupg
local -x REAL_GPG_BIN="${BROOT}"/usr/bin/gpg
diff --git a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.1.ebuild b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.1-r1.ebuild
index c9deedb94c85..7fc3f4de8de3 100644
--- a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.1.ebuild
+++ b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.1-r1.ebuild
@@ -392,8 +392,10 @@ CRATES="
zerovec@0.10.3
"
-LLVM_COMPAT=( {17..18} )
-inherit cargo llvm-r1 xdg-utils
+LLVM_COMPAT=( 17 18 )
+RUST_NEEDS_LLVM=1
+
+inherit llvm-r1 cargo xdg-utils
DESCRIPTION="Sequoia's reimplementation of the GnuPG interface"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-chameleon-gnupg/"
@@ -427,11 +429,15 @@ BDEPEND="
$(llvm_gen_dep '
sys-devel/clang:${LLVM_SLOT}
')
- >=virtual/rust-1.70
"
QA_FLAGS_IGNORED="usr/bin/gpg-sq usr/bin/gpgv-sq"
+pkg_setup() {
+ llvm_r1_pkg_setup
+ rust_pkg_setup
+}
+
src_test() {
local -x GNUPGHOME="${T}"/.gnupg
local -x REAL_GPG_BIN="${BROOT}"/usr/bin/gpg
diff --git a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.8.0.ebuild b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.8.0-r1.ebuild
index b76dcfd07db1..b38f75ac05fc 100644
--- a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.8.0.ebuild
+++ b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.8.0-r1.ebuild
@@ -365,8 +365,10 @@ CRATES="
zeroize@1.7.0
"
-LLVM_COMPAT=( {17..18} )
-inherit cargo llvm-r1 xdg-utils
+LLVM_COMPAT=( 17 18 )
+RUST_NEEDS_LLVM=1
+
+inherit llvm-r1 cargo xdg-utils
DESCRIPTION="Sequoia's reimplementation of the GnuPG interface"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-chameleon-gnupg/"
@@ -400,11 +402,15 @@ BDEPEND="
$(llvm_gen_dep '
sys-devel/clang:${LLVM_SLOT}
')
- >=virtual/rust-1.70
"
QA_FLAGS_IGNORED="usr/bin/gpg-sq usr/bin/gpgv-sq"
+pkg_setup() {
+ llvm_r1_pkg_setup
+ rust_pkg_setup
+}
+
src_test() {
local -x GNUPGHOME="${T}"/.gnupg
local -x REAL_GPG_BIN="${BROOT}"/usr/bin/gpg
diff --git a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.9.0.ebuild b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.9.0-r1.ebuild
index b28c6c443ec4..0e53cf510e24 100644
--- a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.9.0.ebuild
+++ b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.9.0-r1.ebuild
@@ -368,8 +368,10 @@ CRATES="
zeroize@1.7.0
"
-LLVM_COMPAT=( {17..18} )
-inherit cargo llvm-r1 xdg-utils
+LLVM_COMPAT=( 17 18 )
+RUST_NEEDS_LLVM=1
+
+inherit llvm-r1 cargo xdg-utils
DESCRIPTION="Sequoia's reimplementation of the GnuPG interface"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-chameleon-gnupg/"
@@ -403,11 +405,15 @@ BDEPEND="
$(llvm_gen_dep '
sys-devel/clang:${LLVM_SLOT}
')
- >=virtual/rust-1.70
"
QA_FLAGS_IGNORED="usr/bin/gpg-sq usr/bin/gpgv-sq"
+pkg_setup() {
+ llvm_r1_pkg_setup
+ rust_pkg_setup
+}
+
src_test() {
local -x GNUPGHOME="${T}"/.gnupg
local -x REAL_GPG_BIN="${BROOT}"/usr/bin/gpg
diff --git a/app-crypt/sequoia-sq/sequoia-sq-0.35.0.ebuild b/app-crypt/sequoia-sq/sequoia-sq-0.35.0-r1.ebuild
index 5ff711b14f9a..e1cdf632523b 100644
--- a/app-crypt/sequoia-sq/sequoia-sq-0.35.0.ebuild
+++ b/app-crypt/sequoia-sq/sequoia-sq-0.35.0-r1.ebuild
@@ -487,7 +487,7 @@ CRATES="
LLVM_COMPAT=( {16..17} )
-inherit cargo shell-completion llvm-r1
+inherit llvm-r1 cargo shell-completion
DESCRIPTION="CLI of the Sequoia OpenPGP implementation"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-sq"
@@ -528,9 +528,13 @@ BDEPEND="
sys-devel/clang:${LLVM_SLOT}
')
virtual/pkgconfig
- >=virtual/rust-1.70
"
+pkg_setup() {
+ llvm_r1_pkg_setup
+ rust_pkg_setup
+}
+
src_compile() {
# Set this here so that it doesn't change if we run tests
# and cause a recompilation.
diff --git a/app-crypt/sequoia-sq/sequoia-sq-0.36.0.ebuild b/app-crypt/sequoia-sq/sequoia-sq-0.36.0-r1.ebuild
index b2cd91a0baa2..5434f7d3b001 100644
--- a/app-crypt/sequoia-sq/sequoia-sq-0.36.0.ebuild
+++ b/app-crypt/sequoia-sq/sequoia-sq-0.36.0-r1.ebuild
@@ -491,7 +491,7 @@ CRATES="
LLVM_COMPAT=( {16..18} )
-inherit cargo shell-completion llvm-r1
+inherit llvm-r1 cargo shell-completion
DESCRIPTION="CLI of the Sequoia OpenPGP implementation"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-sq"
@@ -532,9 +532,13 @@ BDEPEND="
sys-devel/clang:${LLVM_SLOT}
')
virtual/pkgconfig
- >=virtual/rust-1.70
"
+pkg_setup() {
+ llvm_r1_pkg_setup
+ rust_pkg_setup
+}
+
src_compile() {
# Set this here so that it doesn't change if we run tests
# and cause a recompilation.
diff --git a/app-crypt/sequoia-sq/sequoia-sq-0.37.0.ebuild b/app-crypt/sequoia-sq/sequoia-sq-0.37.0-r1.ebuild
index 03427bf5486d..ce8075c0d2dc 100644
--- a/app-crypt/sequoia-sq/sequoia-sq-0.37.0.ebuild
+++ b/app-crypt/sequoia-sq/sequoia-sq-0.37.0-r1.ebuild
@@ -517,7 +517,7 @@ CRATES="
LLVM_COMPAT=( {16..18} )
-inherit cargo shell-completion llvm-r1
+inherit llvm-r1 cargo shell-completion
DESCRIPTION="CLI of the Sequoia OpenPGP implementation"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-sq"
@@ -558,9 +558,13 @@ BDEPEND="
sys-devel/clang:${LLVM_SLOT}
')
virtual/pkgconfig
- >=virtual/rust-1.70
"
+pkg_setup() {
+ llvm_r1_pkg_setup
+ rust_pkg_setup
+}
+
src_compile() {
# Set this here so that it doesn't change if we run tests
# and cause a recompilation.
diff --git a/app-crypt/sequoia-sqv/sequoia-sqv-1.2.1.ebuild b/app-crypt/sequoia-sqv/sequoia-sqv-1.2.1-r1.ebuild
index 4352e534ebb9..cd4d8540631c 100644
--- a/app-crypt/sequoia-sqv/sequoia-sqv-1.2.1.ebuild
+++ b/app-crypt/sequoia-sqv/sequoia-sqv-1.2.1-r1.ebuild
@@ -251,8 +251,9 @@ CRATES="
"
LLVM_COMPAT=( {17..18} )
+RUST_NEEDS_LLVM=1
-inherit bash-completion-r1 cargo llvm-r1
+inherit bash-completion-r1 llvm-r1 cargo
DESCRIPTION="A simple OpenPGP signature verification program"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-sqv"
@@ -290,6 +291,11 @@ BDEPEND="
virtual/pkgconfig
"
+pkg_setup() {
+ llvm-r1_pkg_setup
+ rust_pkg_setup
+}
+
src_compile() {
# Set this here so that it doesn't change if we run tests
# and cause a recompilation.