summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-10 11:24:12 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-11 18:49:16 +1000
commit20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3 (patch)
tree717d375d4bc34b50cfb78c9712a992489ed8d73b /app-crypt
parenteclass: update rust usedep handling; address feedback (diff)
downloadgentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.gz
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.bz2
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.zip
*/*: fix rust eclass usedep/mutlilib handling; inherit order
The rust eclass has been updated to directly inject a required MULTILIB_USEDEP when requested. RUST_USEDEP has been renamed to RUST_REQUIRED_USE to be consistent with other eclasses. llvm-r1 should be imported after cargo and the eclass now enables this. Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild2
-rw-r--r--app-crypt/rpm-sequoia/rpm-sequoia-1.7.0-r1.ebuild2
-rw-r--r--app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.0-r1.ebuild2
-rw-r--r--app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.1-r1.ebuild2
-rw-r--r--app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.8.0-r1.ebuild2
-rw-r--r--app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.9.0-r1.ebuild2
-rw-r--r--app-crypt/sequoia-sq/sequoia-sq-0.35.0-r1.ebuild2
-rw-r--r--app-crypt/sequoia-sq/sequoia-sq-0.36.0-r1.ebuild2
-rw-r--r--app-crypt/sequoia-sq/sequoia-sq-0.37.0-r1.ebuild2
-rw-r--r--app-crypt/sequoia-sqv/sequoia-sqv-1.2.1-r1.ebuild2
10 files changed, 10 insertions, 10 deletions
diff --git a/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild b/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild
index 1563c0d6977e..afd0c9eb297b 100644
--- a/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild
+++ b/app-crypt/rpm-sequoia/rpm-sequoia-1.6.0-r1.ebuild
@@ -238,7 +238,7 @@ CRATES="
LLVM_COMPAT=( 17 )
RUST_NEEDS_LLVM=1
-inherit llvm-r1 cargo
+inherit cargo llvm-r1
DESCRIPTION="Implementation of the RPM PGP interface using Sequoia"
HOMEPAGE="https://sequoia-pgp.org/ https://github.com/rpm-software-management/rpm-sequoia"
diff --git a/app-crypt/rpm-sequoia/rpm-sequoia-1.7.0-r1.ebuild b/app-crypt/rpm-sequoia/rpm-sequoia-1.7.0-r1.ebuild
index c5c225f601ba..6c85a5471878 100644
--- a/app-crypt/rpm-sequoia/rpm-sequoia-1.7.0-r1.ebuild
+++ b/app-crypt/rpm-sequoia/rpm-sequoia-1.7.0-r1.ebuild
@@ -252,7 +252,7 @@ LLVM_COMPAT=( 17 18 )
RUST_MIN_VER="1.74.1"
RUST_NEEDS_LLVM=1
-inherit llvm-r1 cargo
+inherit cargo llvm-r1
DESCRIPTION="Implementation of the RPM PGP interface using Sequoia"
HOMEPAGE="https://sequoia-pgp.org/ https://github.com/rpm-software-management/rpm-sequoia"
diff --git a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.0-r1.ebuild b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.0-r1.ebuild
index d9f7fe6ff6c5..64b191ed02db 100644
--- a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.0-r1.ebuild
+++ b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.0-r1.ebuild
@@ -397,7 +397,7 @@ CRATES="
LLVM_COMPAT=( 17 18 )
RUST_NEEDS_LLVM=1
-inherit llvm-r1 cargo xdg-utils
+inherit cargo llvm-r1 xdg-utils
DESCRIPTION="Sequoia's reimplementation of the GnuPG interface"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-chameleon-gnupg/"
diff --git a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.1-r1.ebuild b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.1-r1.ebuild
index 0e7e1f4a83bc..afaeb7fd6362 100644
--- a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.1-r1.ebuild
+++ b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.10.1-r1.ebuild
@@ -395,7 +395,7 @@ CRATES="
LLVM_COMPAT=( 17 18 )
RUST_NEEDS_LLVM=1
-inherit llvm-r1 cargo xdg-utils
+inherit cargo llvm-r1 xdg-utils
DESCRIPTION="Sequoia's reimplementation of the GnuPG interface"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-chameleon-gnupg/"
diff --git a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.8.0-r1.ebuild b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.8.0-r1.ebuild
index 9d7e03abe6f4..95658418e7e9 100644
--- a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.8.0-r1.ebuild
+++ b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.8.0-r1.ebuild
@@ -368,7 +368,7 @@ CRATES="
LLVM_COMPAT=( 17 18 )
RUST_NEEDS_LLVM=1
-inherit llvm-r1 cargo xdg-utils
+inherit cargo llvm-r1 xdg-utils
DESCRIPTION="Sequoia's reimplementation of the GnuPG interface"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-chameleon-gnupg/"
diff --git a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.9.0-r1.ebuild b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.9.0-r1.ebuild
index 15f622ec15e0..e1f74372c492 100644
--- a/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.9.0-r1.ebuild
+++ b/app-crypt/sequoia-chameleon-gnupg/sequoia-chameleon-gnupg-0.9.0-r1.ebuild
@@ -371,7 +371,7 @@ CRATES="
LLVM_COMPAT=( 17 18 )
RUST_NEEDS_LLVM=1
-inherit llvm-r1 cargo xdg-utils
+inherit cargo llvm-r1 xdg-utils
DESCRIPTION="Sequoia's reimplementation of the GnuPG interface"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-chameleon-gnupg/"
diff --git a/app-crypt/sequoia-sq/sequoia-sq-0.35.0-r1.ebuild b/app-crypt/sequoia-sq/sequoia-sq-0.35.0-r1.ebuild
index 17375661ac23..bac089222857 100644
--- a/app-crypt/sequoia-sq/sequoia-sq-0.35.0-r1.ebuild
+++ b/app-crypt/sequoia-sq/sequoia-sq-0.35.0-r1.ebuild
@@ -487,7 +487,7 @@ CRATES="
LLVM_COMPAT=( {16..17} )
-inherit llvm-r1 cargo shell-completion
+inherit cargo llvm-r1 shell-completion
DESCRIPTION="CLI of the Sequoia OpenPGP implementation"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-sq"
diff --git a/app-crypt/sequoia-sq/sequoia-sq-0.36.0-r1.ebuild b/app-crypt/sequoia-sq/sequoia-sq-0.36.0-r1.ebuild
index 9a186810fb28..784b920e5d85 100644
--- a/app-crypt/sequoia-sq/sequoia-sq-0.36.0-r1.ebuild
+++ b/app-crypt/sequoia-sq/sequoia-sq-0.36.0-r1.ebuild
@@ -491,7 +491,7 @@ CRATES="
LLVM_COMPAT=( {16..18} )
-inherit llvm-r1 cargo shell-completion
+inherit cargo llvm-r1 shell-completion
DESCRIPTION="CLI of the Sequoia OpenPGP implementation"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-sq"
diff --git a/app-crypt/sequoia-sq/sequoia-sq-0.37.0-r1.ebuild b/app-crypt/sequoia-sq/sequoia-sq-0.37.0-r1.ebuild
index c51436d42641..16c18d31960d 100644
--- a/app-crypt/sequoia-sq/sequoia-sq-0.37.0-r1.ebuild
+++ b/app-crypt/sequoia-sq/sequoia-sq-0.37.0-r1.ebuild
@@ -517,7 +517,7 @@ CRATES="
LLVM_COMPAT=( {16..18} )
-inherit llvm-r1 cargo shell-completion
+inherit cargo llvm-r1 shell-completion
DESCRIPTION="CLI of the Sequoia OpenPGP implementation"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-sq"
diff --git a/app-crypt/sequoia-sqv/sequoia-sqv-1.2.1-r1.ebuild b/app-crypt/sequoia-sqv/sequoia-sqv-1.2.1-r1.ebuild
index cd4d8540631c..980514150d8f 100644
--- a/app-crypt/sequoia-sqv/sequoia-sqv-1.2.1-r1.ebuild
+++ b/app-crypt/sequoia-sqv/sequoia-sqv-1.2.1-r1.ebuild
@@ -253,7 +253,7 @@ CRATES="
LLVM_COMPAT=( {17..18} )
RUST_NEEDS_LLVM=1
-inherit bash-completion-r1 llvm-r1 cargo
+inherit bash-completion-r1 cargo llvm-r1
DESCRIPTION="A simple OpenPGP signature verification program"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia-sqv"