summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-09 22:48:21 +0000
committerSam James <sam@gentoo.org>2021-03-09 22:49:42 +0000
commit434ea14657a635360b4efb3a01ea7b5d0753a168 (patch)
treeef1343c1af36ecee0a74f86a9b440a7c3b267cdb /app-crypt
parentnet-misc/cadaver: Create config.rpath for newer Autoconf. (diff)
downloadgentoo-434ea14657a635360b4efb3a01ea7b5d0753a168.tar.gz
gentoo-434ea14657a635360b4efb3a01ea7b5d0753a168.tar.bz2
gentoo-434ea14657a635360b4efb3a01ea7b5d0753a168.zip
app-crypt/libmd: drop .la files with find, sync live
Closes: https://bugs.gentoo.org/775161 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libmd/libmd-1.0.3.ebuild2
-rw-r--r--app-crypt/libmd/libmd-99999.ebuild8
2 files changed, 4 insertions, 6 deletions
diff --git a/app-crypt/libmd/libmd-1.0.3.ebuild b/app-crypt/libmd/libmd-1.0.3.ebuild
index 8a326814c160..f4e3c0857bdd 100644
--- a/app-crypt/libmd/libmd-1.0.3.ebuild
+++ b/app-crypt/libmd/libmd-1.0.3.ebuild
@@ -20,5 +20,5 @@ src_configure() {
src_install() {
default
- rm "${ED}"/usr/$(get_libdir)/libmd.la || die
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/app-crypt/libmd/libmd-99999.ebuild b/app-crypt/libmd/libmd-99999.ebuild
index c0ad8d6375b2..b7ba4f0339ba 100644
--- a/app-crypt/libmd/libmd-99999.ebuild
+++ b/app-crypt/libmd/libmd-99999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools git-r3
DESCRIPTION="Message Digest functions from BSD systems"
@@ -10,16 +11,13 @@ EGIT_REPO_URI="https://git.hadrons.org/git/libmd.git"
LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
SLOT="0"
-KEYWORDS=""
-IUSE="static-libs"
src_prepare() {
default
- eautoreconf
}
src_configure() {
- econf $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {