summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-07 15:31:18 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 20:47:33 +0200
commitbacd560dd716ad0ff3ada025ec8a697fed31df28 (patch)
treeb6f8a5e81d9fb8eb1cf4591e58c31b90907fb701 /app-dicts/verbiste/verbiste-0.1.48.ebuild
parentapp-crypt/aescrypt: add 3.16 (diff)
downloadgentoo-bacd560dd716ad0ff3ada025ec8a697fed31df28.tar.gz
gentoo-bacd560dd716ad0ff3ada025ec8a697fed31df28.tar.bz2
gentoo-bacd560dd716ad0ff3ada025ec8a697fed31df28.zip
app-dicts/verbiste: add 0.1.48
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37071 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-dicts/verbiste/verbiste-0.1.48.ebuild')
-rw-r--r--app-dicts/verbiste/verbiste-0.1.48.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-dicts/verbiste/verbiste-0.1.48.ebuild b/app-dicts/verbiste/verbiste-0.1.48.ebuild
new file mode 100644
index 000000000000..b5a0b66f3fe5
--- /dev/null
+++ b/app-dicts/verbiste/verbiste-0.1.48.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg-utils
+
+DESCRIPTION="French conjugation system"
+HOMEPAGE="http://sarrazip.com/dev/verbiste.html"
+SRC_URI="http://sarrazip.com/dev/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.4.0:2
+ gtk? ( >=x11-libs/gtk+-2.6:2 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --with-console-app
+ --without-gnome-app
+ --without-gnome-applet
+ $(use_with gtk gtk-app)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ dodoc HACKING LISEZMOI
+ # file is only installed with USE=gnome
+ if use gtk; then
+ sed -e 's/Exec=.*/Exec=verbiste-gtk/' \
+ -i src/gnome/verbiste.desktop || die
+ domenu src/gnome/verbiste.desktop
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if use gtk; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}