summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /app-editors
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/helix/helix-24.03-r2.ebuild (renamed from app-editors/helix/helix-24.03-r1.ebuild)0
-rw-r--r--app-editors/helix/helix-24.07-r1.ebuild (renamed from app-editors/helix/helix-24.07.ebuild)1
-rw-r--r--app-editors/zed/zed-0.155.2-r1.ebuild (renamed from app-editors/zed/zed-0.155.2.ebuild)7
-rw-r--r--app-editors/zed/zed-0.159.10-r1.ebuild (renamed from app-editors/zed/zed-0.159.10.ebuild)7
-rw-r--r--app-editors/zed/zed-0.160.7-r1.ebuild (renamed from app-editors/zed/zed-0.160.7.ebuild)7
5 files changed, 16 insertions, 6 deletions
diff --git a/app-editors/helix/helix-24.03-r1.ebuild b/app-editors/helix/helix-24.03-r2.ebuild
index 46ee3c25397e..46ee3c25397e 100644
--- a/app-editors/helix/helix-24.03-r1.ebuild
+++ b/app-editors/helix/helix-24.03-r2.ebuild
diff --git a/app-editors/helix/helix-24.07.ebuild b/app-editors/helix/helix-24.07-r1.ebuild
index 89deeb654e5f..23c9065f87bd 100644
--- a/app-editors/helix/helix-24.07.ebuild
+++ b/app-editors/helix/helix-24.07-r1.ebuild
@@ -311,6 +311,7 @@ pkg_setup() {
"
export HELIX_DEFAULT_RUNTIME="${EPREFIX}/usr/share/${PN}/runtime"
use grammar || export HELIX_DISABLE_AUTO_GRAMMAR_BUILD=1
+ rust_pkg_setup
}
src_install() {
diff --git a/app-editors/zed/zed-0.155.2.ebuild b/app-editors/zed/zed-0.155.2-r1.ebuild
index b4cace50d25f..7ac2746fed38 100644
--- a/app-editors/zed/zed-0.155.2.ebuild
+++ b/app-editors/zed/zed-0.155.2-r1.ebuild
@@ -31,8 +31,10 @@ declare -A GIT_CRATES=(
)
LLVM_COMPAT=( 18 )
+RUST_MIN_VER="1.80.1"
+RUST_NEEDS_LLVM=1
-inherit cargo check-reqs desktop flag-o-matic llvm-r1 toolchain-funcs xdg
+inherit llvm-r1 cargo check-reqs desktop flag-o-matic toolchain-funcs xdg
DESCRIPTION="The fast, collaborative code editor"
HOMEPAGE="https://zed.dev https://github.com/zed-industries/zed"
@@ -74,7 +76,6 @@ DEPEND="
"
RDEPEND="${DEPEND}"
BDEPEND="
- >=virtual/rust-1.80.0
dev-util/vulkan-headers
sys-devel/gettext
sys-devel/mold
@@ -97,6 +98,8 @@ pkg_setup() {
export RUSTFLAGS="${RUSTFLAGS} -C symbol-mangling-version=v0 --cfg tokio_unstable -C link-arg=-fuse-ld=mold -C link-args=-Wl,--disable-new-dtags,-rpath,\$ORIGIN/../lib"
# linking error with llvm-18
export RUSTFLAGS="${RUSTFLAGS} -C link-args=-Wl,-z,nostart-stop-gc"
+ llvm-r1_pkg_setup
+ rust_pkg_setup
}
src_prepare() {
diff --git a/app-editors/zed/zed-0.159.10.ebuild b/app-editors/zed/zed-0.159.10-r1.ebuild
index 63b11db2c3dd..6b5c07a29c86 100644
--- a/app-editors/zed/zed-0.159.10.ebuild
+++ b/app-editors/zed/zed-0.159.10-r1.ebuild
@@ -55,8 +55,10 @@ declare -A GIT_CRATES=(
)
LLVM_COMPAT=( 18 )
+RUST_MIN_VER="1.80.1"
+RUST_NEEDS_LLVM=1
-inherit cargo check-reqs desktop flag-o-matic llvm-r1 toolchain-funcs xdg
+inherit llvm-r1 cargo check-reqs desktop flag-o-matic toolchain-funcs xdg
DESCRIPTION="The fast, collaborative code editor"
HOMEPAGE="https://zed.dev https://github.com/zed-industries/zed"
@@ -103,7 +105,6 @@ BDEPEND="
dev-util/vulkan-headers
sys-devel/gettext
sys-devel/mold
- >=virtual/rust-1.80.0
$(llvm_gen_dep '
sys-devel/clang:${LLVM_SLOT}=
sys-devel/llvm:${LLVM_SLOT}=
@@ -126,6 +127,8 @@ pkg_setup() {
if use gles; then
export RUSTFLAGS="${RUSTFLAGS} --cfg gles"
fi
+ llvm-r1_pkg_setup
+ rust_pkg_setup
}
src_prepare() {
diff --git a/app-editors/zed/zed-0.160.7.ebuild b/app-editors/zed/zed-0.160.7-r1.ebuild
index 63b11db2c3dd..6b5c07a29c86 100644
--- a/app-editors/zed/zed-0.160.7.ebuild
+++ b/app-editors/zed/zed-0.160.7-r1.ebuild
@@ -55,8 +55,10 @@ declare -A GIT_CRATES=(
)
LLVM_COMPAT=( 18 )
+RUST_MIN_VER="1.80.1"
+RUST_NEEDS_LLVM=1
-inherit cargo check-reqs desktop flag-o-matic llvm-r1 toolchain-funcs xdg
+inherit llvm-r1 cargo check-reqs desktop flag-o-matic toolchain-funcs xdg
DESCRIPTION="The fast, collaborative code editor"
HOMEPAGE="https://zed.dev https://github.com/zed-industries/zed"
@@ -103,7 +105,6 @@ BDEPEND="
dev-util/vulkan-headers
sys-devel/gettext
sys-devel/mold
- >=virtual/rust-1.80.0
$(llvm_gen_dep '
sys-devel/clang:${LLVM_SLOT}=
sys-devel/llvm:${LLVM_SLOT}=
@@ -126,6 +127,8 @@ pkg_setup() {
if use gles; then
export RUSTFLAGS="${RUSTFLAGS} --cfg gles"
fi
+ llvm-r1_pkg_setup
+ rust_pkg_setup
}
src_prepare() {