summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2016-12-21 22:17:51 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2017-01-04 23:37:07 +0100
commit5ca3a30c0a1e7285d352b8e312e6e89091aecd69 (patch)
treecdb7564878ac57b56b72819f8405d2894a9884d5 /app-editors
parentmedia-gfx/shotwell: bump to 0.24.3 (diff)
downloadgentoo-5ca3a30c0a1e7285d352b8e312e6e89091aecd69.tar.gz
gentoo-5ca3a30c0a1e7285d352b8e312e6e89091aecd69.tar.bz2
gentoo-5ca3a30c0a1e7285d352b8e312e6e89091aecd69.zip
app-editors/latexila: bump to 3.22.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3208 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/latexila/Manifest1
-rw-r--r--app-editors/latexila/latexila-3.22.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-editors/latexila/Manifest b/app-editors/latexila/Manifest
index dbf8d303be73..55bee8b6697d 100644
--- a/app-editors/latexila/Manifest
+++ b/app-editors/latexila/Manifest
@@ -1,2 +1,3 @@
DIST latexila-3.20.1.tar.xz 1113788 SHA256 58edbe3a1d7734d590ed4b85387fb8ce2e0df351bde9cd25ed3ee29239c81089 SHA512 22fd8eb6f6ae839404a6c1ca25b7bda796bcd740e2a66fde7d4fd92f8d412972b023e1769fda04247a0c0c4d97640b64ca3426d3285b4c94f33429a576d0b2ff WHIRLPOOL 25aadbf3de455277b981d6c33a1cf307423d3c3355b3518acbfb2ea776eb2c463accae2ef24ae90dc5583c3d4069d981d26772f5440085b269f9bc6fe04a0451
DIST latexila-3.22.0.tar.xz 1113648 SHA256 f78b643d95bbc3867430b32684c859a13aa887c1433d0e8df91a51168b564e54 SHA512 dbb2e195fa3224a9c5ce72ccec5c9c9b188c70152534846782791930107a9c9d761edef53bca2bb92ff20dd7c58413ecee2c4fa514d70a2d574b8f7e847b7673 WHIRLPOOL 1f792d4290f081a49be0d2fa0bcdac8b4e87c7d35b2c11d4e9cb3797a744785044ba6ccc0d655b645a3a620956b11b943b67998d5e6469880436a9e35be27c67
+DIST latexila-3.22.1.tar.xz 1111820 SHA256 41692d850a48521d2a700ae296680464078ef0bef1c1383383b433c5ecdf2719 SHA512 7c2d3b95b9547e97c79f5e6384b1f33ccb81e70cea1d26fcc07845f3f391ac54b5931ddcec742f3439ba55e8f9f2a2054935795ab16bee584eb05780a72ba3a9 WHIRLPOOL bacdd353a29c79612bc7f9b786b9c9ff5c4d12bf595b6795eb498251d724be7a29915723e2a0d29ef8bef22b096259da540e8b11d5e6ac4287833abfbc306a9f
diff --git a/app-editors/latexila/latexila-3.22.1.ebuild b/app-editors/latexila/latexila-3.22.1.ebuild
new file mode 100644
index 000000000000..15ac698ad3da
--- /dev/null
+++ b/app-editors/latexila/latexila-3.22.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/LaTeXila"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection +latexmk rubber"
+
+COMMON_DEPEND="
+ $(vala_depend)
+ app-text/enchant
+ >=app-text/gspell-1.0:0=
+ >=dev-libs/glib-2.40:2[dbus]
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/gtksourceview-3.18:3.0=
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50.1
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection)
+}