summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-03 06:17:13 -0700
committerMatt Turner <mattst88@gentoo.org>2022-05-03 06:47:54 -0700
commita4900ba79d9d25851f7aea70d2ec4d0d1e988916 (patch)
treee8618bc499b239118d16e1df6ab675a36499d2e0 /app-editors
parentgui-libs/tepl: Version bump to 6.0.1 (diff)
downloadgentoo-a4900ba79d9d25851f7aea70d2ec4d0d1e988916.tar.gz
gentoo-a4900ba79d9d25851f7aea70d2ec4d0d1e988916.tar.bz2
gentoo-a4900ba79d9d25851f7aea70d2ec4d0d1e988916.zip
app-editors/gnome-latex: Version bump to 3.40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gnome-latex/Manifest1
-rw-r--r--app-editors/gnome-latex/gnome-latex-3.40.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-editors/gnome-latex/Manifest b/app-editors/gnome-latex/Manifest
index ffe12a3b6f19..f04a8638c367 100644
--- a/app-editors/gnome-latex/Manifest
+++ b/app-editors/gnome-latex/Manifest
@@ -1 +1,2 @@
DIST gnome-latex-3.38.0.tar.xz 1094376 BLAKE2B 0c02996dbac48c3859d33a0d504a64462e306d346ca22397820231fa8fe7ce2aa621a1435a02d78ea424fc8e9f5b7ac6e3e60180d8212c170d52eb4baee3b94a SHA512 c42cc1ff2c59afe4d995e9f13d9a858e2297827d5f9359cecd969d305224fc4b4d0306e0ab6aa1d9b7fc92acc25e597319299afe176cff1903f734fbc2ddf29b
+DIST gnome-latex-3.40.0.tar.xz 1050088 BLAKE2B bd8764450ee122599fd96a7e889291805fc09d854d77aa4e7d3b01709cda8bf0c38327d05de6117a19f325ca6a61ab42e014d27b941ed8e40f0bfd963dd65680 SHA512 822d86eac81994593e71428f1c893ce7d6970bb8e98349c8ad9cc6a113e3fdb49209f1bc7f19fb8d5a22da98d7650a822c8f8ab1f5aa096e6ea0cbaf74dfafca
diff --git a/app-editors/gnome-latex/gnome-latex-3.40.0.ebuild b/app-editors/gnome-latex/gnome-latex-3.40.0.ebuild
new file mode 100644
index 000000000000..1f9a45676081
--- /dev/null
+++ b/app-editors/gnome-latex/gnome-latex-3.40.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/GNOME-LaTeX https://gitlab.gnome.org/swilmet/gnome-latex"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+introspection +latexmk rubber"
+
+DEPEND="
+ >=app-text/gspell-1.8:0=
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0:4
+ >=gui-libs/amtk-5.2:5
+ >=gui-libs/tepl-6.0.1:6
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ gnome-base/dconf
+"
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-dconf_migration \
+ --enable-vala=no
+}