summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVarsha Teratipally <teratipally@google.com>2022-08-02 23:11:58 +0000
committerSam James <sam@gentoo.org>2022-08-17 20:52:24 +0100
commitd843df829420e93e0bac9f5430d878a8438ec51a (patch)
tree77f7f7fbf369107347da1130dd60286d4e0ac785 /app-editors
parentdev-python/pyinotify: drop 0.9.6 (diff)
downloadgentoo-d843df829420e93e0bac9f5430d878a8438ec51a.tar.gz
gentoo-d843df829420e93e0bac9f5430d878a8438ec51a.tar.bz2
gentoo-d843df829420e93e0bac9f5430d878a8438ec51a.zip
app-editors/vim: fix cross-compilation (configure check for timer_create)
Problem: Configure check for timer_create may give wrong error. Solution: Give a warning instead of an error. Closes:https://github.com/gentoo/gentoo/pull/26713 Signed-off-by: Varsha Teratipally <teratipally@google.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/files/vim-9.0-fix-create-timer-for-cros-compiling.patch28
-rw-r--r--app-editors/vim/vim-9.0.0049.ebuild2
-rw-r--r--app-editors/vim/vim-9.0.0099.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/app-editors/vim/files/vim-9.0-fix-create-timer-for-cros-compiling.patch b/app-editors/vim/files/vim-9.0-fix-create-timer-for-cros-compiling.patch
new file mode 100644
index 000000000000..5247a80754cc
--- /dev/null
+++ b/app-editors/vim/files/vim-9.0-fix-create-timer-for-cros-compiling.patch
@@ -0,0 +1,28 @@
+From bba26c9ed9d4ddc82afd0343f145dc9e14b91498 Mon Sep 17 00:00:00 2001
+From: Varsha Teratipally <teratipally@google.com>
+Date: Tue, 2 Aug 2022 22:18:29 +0000
+Subject: [PATCH] Configure check for timer_create may give wrong error.
+Give a warning instead of an error
+
+Partial solution from github.com/vim/vim/commit/5f6cae8b8a49c435556e32f84d067cd0b4d28e4c
+
+---
+ src/configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/configure.ac b/src/configure.ac
+index e8522ec05..41f41dee3 100644
+--- a/src/configure.ac
++++ b/src/configure.ac
+@@ -3850,7 +3850,7 @@ static void set_flag(union sigval sv) {}
+ ])],
+ vim_cv_timer_create=yes,
+ vim_cv_timer_create=no),
+- AC_MSG_ERROR(cross-compiling: please set 'vim_cv_timer_create')
++ AC_MSG_WARN(cross-compiling: please set 'vim_cv_timer_create')
+ )]
+ )
+
+--
+
+
diff --git a/app-editors/vim/vim-9.0.0049.ebuild b/app-editors/vim/vim-9.0.0049.ebuild
index 38aa4796d06e..9bd88fc46ed9 100644
--- a/app-editors/vim/vim-9.0.0049.ebuild
+++ b/app-editors/vim/vim-9.0.0049.ebuild
@@ -78,7 +78,7 @@ src_prepare() {
if [[ ${PV} != 9999* ]] ; then
# Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}/vim-patches-vim-9.0.0049-patches"
+ eapply "${WORKDIR}"/vim-patches-vim-9.0.0049-patches
fi
# Fixup a script to use awk instead of nawk
diff --git a/app-editors/vim/vim-9.0.0099.ebuild b/app-editors/vim/vim-9.0.0099.ebuild
index 20b1576997d4..b3882ef81361 100644
--- a/app-editors/vim/vim-9.0.0099.ebuild
+++ b/app-editors/vim/vim-9.0.0099.ebuild
@@ -78,7 +78,8 @@ src_prepare() {
if [[ ${PV} != 9999* ]] ; then
# Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}/vim-patches-vim-9.0.0049-patches"
+ eapply "${WORKDIR}"/vim-patches-vim-9.0.0049-patches
+ eapply "${FILESDIR}"/vim-9.0-fix-create-timer-for-cros-compiling.patch
fi
# Fixup a script to use awk instead of nawk