summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-17 02:04:23 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-17 02:17:22 +0200
commit77292f2d1dd578e71e1a9a0af4492c55413124bb (patch)
treeebc0fed13e9af662f55b44fb00749ba6aa67a92b /app-emacs/exec-path-from-shell
parentnet-fs/autofs: fix redefinition of struct mount_attr err (diff)
downloadgentoo-77292f2d1dd578e71e1a9a0af4492c55413124bb.tar.gz
gentoo-77292f2d1dd578e71e1a9a0af4492c55413124bb.tar.bz2
gentoo-77292f2d1dd578e71e1a9a0af4492c55413124bb.zip
app-emacs/exec-path-from-shell: new package; add version 1.12
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/exec-path-from-shell')
-rw-r--r--app-emacs/exec-path-from-shell/Manifest1
-rw-r--r--app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild24
-rw-r--r--app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el2
-rw-r--r--app-emacs/exec-path-from-shell/metadata.xml20
4 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/exec-path-from-shell/Manifest b/app-emacs/exec-path-from-shell/Manifest
new file mode 100644
index 000000000000..7b96288e36e8
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/Manifest
@@ -0,0 +1 @@
+DIST exec-path-from-shell-1.12.tar.gz 17125 BLAKE2B 01440c4f484fa2e584c40961cc3a0199a812072b3a41c78833a43bd57105e677077f902ef40dbb68eeaaa84fc511d9e02d7fabdbd7c86a0bc57e1ba88aaa6888 SHA512 62f0f89f542cbf0edaf163c1dfd4fac8bb532898f8eb5a9e068a991eaddb5e6ecb1813fc76252dc2d48b42b9ab602082f612d241613002b1a37b4f7d5f5d4f3c
diff --git a/app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild b/app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild
new file mode 100644
index 000000000000..f21f1c54ffd5
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.1
+
+inherit elisp
+
+DESCRIPTION="Ensure environment variables inside Emacs are the same as in shell"
+HOMEPAGE="https://github.com/purcell/exec-path-from-shell/"
+SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el b/app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el
new file mode 100644
index 000000000000..6fa79c9aefcf
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "exec-path-from-shell-autoloads" nil t)
diff --git a/app-emacs/exec-path-from-shell/metadata.xml b/app-emacs/exec-path-from-shell/metadata.xml
new file mode 100644
index 000000000000..053f64ad6502
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This library allows the user to set Emacs' `exec-path' and $PATH from the
+ shell path, so that `shell-command', `compile' and the like work as
+ expected. It also allows other environment variables to be retrieved from
+ the shell, so that Emacs will see the same values you get in a terminal.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/purcell/exec-path-from-shell/issues/</bugs-to>
+ <remote-id type="github">purcell/exec-path-from-shell</remote-id>
+ </upstream>
+</pkgmetadata>