summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-24 15:27:23 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-03-24 15:30:46 +0100
commit04ca5c83b6cce6fb4152fd2f54cd03141505aaaf (patch)
treea7b20c9acb6a9ea9d5fea1f5be515851b1107a2c /app-emacs/flycheck
parentapp-arch/bzip3: bump to 1.2.3 (diff)
downloadgentoo-04ca5c83b6cce6fb4152fd2f54cd03141505aaaf.tar.gz
gentoo-04ca5c83b6cce6fb4152fd2f54cd03141505aaaf.tar.bz2
gentoo-04ca5c83b6cce6fb4152fd2f54cd03141505aaaf.zip
app-emacs/flycheck: guard COMMIT; add support for live
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/flycheck')
-rw-r--r--app-emacs/flycheck/flycheck-32_p20220328-r1.ebuild23
-rw-r--r--app-emacs/flycheck/flycheck-32_p20230305-r1.ebuild23
-rw-r--r--app-emacs/flycheck/flycheck-32_p20230305.ebuild23
3 files changed, 54 insertions, 15 deletions
diff --git a/app-emacs/flycheck/flycheck-32_p20220328-r1.ebuild b/app-emacs/flycheck/flycheck-32_p20220328-r1.ebuild
index 68d7c5475c23..38acdbd6ab11 100644
--- a/app-emacs/flycheck/flycheck-32_p20220328-r1.ebuild
+++ b/app-emacs/flycheck/flycheck-32_p20220328-r1.ebuild
@@ -8,14 +8,27 @@ NEED_EMACS="24.3"
inherit elisp
DESCRIPTION="Modern on-the-fly syntax checking extension for GNU Emacs"
-HOMEPAGE="https://www.flycheck.org/"
-COMMIT="3b5b4248074f016922c2674789d4a242528cf4c7"
-SRC_URI="https://github.com/flycheck/flycheck/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
+HOMEPAGE="https://www.flycheck.org/
+ https://github.com/flycheck/flycheck/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ if [[ ${PV} == *_p20220328 ]] ; then
+ COMMIT=3b5b4248074f016922c2674789d4a242528cf4c7
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ fi
+ KEYWORDS="~alpha amd64 ~arm arm64 ~ppc64 ~riscv ~x64-macos"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ppc64 ~riscv ~x64-macos"
RESTRICT="test" # test requires cask and ert-runner which are not packaged yet
RDEPEND=">=app-emacs/dash-2.12.1
diff --git a/app-emacs/flycheck/flycheck-32_p20230305-r1.ebuild b/app-emacs/flycheck/flycheck-32_p20230305-r1.ebuild
index f1f18ee87b30..144233694866 100644
--- a/app-emacs/flycheck/flycheck-32_p20230305-r1.ebuild
+++ b/app-emacs/flycheck/flycheck-32_p20230305-r1.ebuild
@@ -7,15 +7,28 @@ NEED_EMACS="24.3"
inherit edo elisp
-COMMIT="5f2ef177cb21ae8b73714575802beef04abd0f5e"
DESCRIPTION="Modern on-the-fly syntax checking extension for GNU Emacs"
-HOMEPAGE="https://www.flycheck.org/"
-SRC_URI="https://github.com/flycheck/flycheck/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
+HOMEPAGE="https://www.flycheck.org/
+ https://github.com/flycheck/flycheck/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ if [[ ${PV} == *_p20230305 ]] ; then
+ COMMIT=5f2ef177cb21ae8b73714575802beef04abd0f5e
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ fi
+ KEYWORDS="~amd64 ~arm ~ppc64"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64"
IUSE="test"
# Tests fail for now, need more investigation
RESTRICT="!test? ( test ) test"
diff --git a/app-emacs/flycheck/flycheck-32_p20230305.ebuild b/app-emacs/flycheck/flycheck-32_p20230305.ebuild
index 1ad096748312..2fae67dd6044 100644
--- a/app-emacs/flycheck/flycheck-32_p20230305.ebuild
+++ b/app-emacs/flycheck/flycheck-32_p20230305.ebuild
@@ -8,14 +8,27 @@ NEED_EMACS="24.3"
inherit elisp
DESCRIPTION="Modern on-the-fly syntax checking extension for GNU Emacs"
-HOMEPAGE="https://www.flycheck.org/"
-COMMIT="5f2ef177cb21ae8b73714575802beef04abd0f5e"
-SRC_URI="https://github.com/flycheck/flycheck/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
+HOMEPAGE="https://www.flycheck.org/
+ https://github.com/flycheck/flycheck/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ if [[ ${PV} == *_p20230305 ]] ; then
+ COMMIT=5f2ef177cb21ae8b73714575802beef04abd0f5e
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ fi
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x64-macos"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x64-macos"
RESTRICT="test" # TODO: wire up now that cask and ert-runner are packaged
RDEPEND=">=app-emacs/dash-2.12.1