summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/howm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/howm')
-rw-r--r--app-emacs/howm/Manifest2
-rw-r--r--app-emacs/howm/files/50howm-gentoo.el2
-rw-r--r--app-emacs/howm/howm-1.3.9.1.ebuild43
-rw-r--r--app-emacs/howm/howm-1.3.9.2.ebuild43
-rw-r--r--app-emacs/howm/metadata.xml5
5 files changed, 95 insertions, 0 deletions
diff --git a/app-emacs/howm/Manifest b/app-emacs/howm/Manifest
new file mode 100644
index 000000000000..9b6cf6396f98
--- /dev/null
+++ b/app-emacs/howm/Manifest
@@ -0,0 +1,2 @@
+DIST howm-1.3.9.1.tar.gz 455351 SHA256 c4e5760bc226d7a523906cbe74f961659ccbf878eda2bf0e7d91fe7022e60e55 SHA512 25aeb31db43e1b51ac026926b048ac5e1b15c2c6eecd72bf3a5ce2b12e29f03a059c840c0cb9d8818a9f5b168441cc01b987edd54b5d8cb7ce473c05945dd95d WHIRLPOOL 904e697edda6e439666f3d5f8ecddf2a7482c8fad6ea7e9bc1a9024114c8934f852751614a814e1e9284f26e97507b74c13baa233c7fdc40e3130b10d787fa01
+DIST howm-1.3.9.2.tar.gz 462278 SHA256 baff5ce28580502a876600350b7eac5d5bf1cd32ba60c115cbb9edc2ac63d578 SHA512 34e867d35ac8a2092b29d24ec1673255fcce54369d3aa2e6497ea4c891d4ea7f038e80f6103ad1f6359d8390a5d9a57901019cd3d76cc24e439b44dba5cc27bf WHIRLPOOL eafd272caec4437f94b5594c9375f7d999db65b0f15535d291ce02ae1ce090ecbed09acef0de07b558e703b09791d8fb66dab79b73738b0bf56ee3b36979c050
diff --git a/app-emacs/howm/files/50howm-gentoo.el b/app-emacs/howm/files/50howm-gentoo.el
new file mode 100644
index 000000000000..d5dc8180f379
--- /dev/null
+++ b/app-emacs/howm/files/50howm-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'howm-menu "howm" nil t)
diff --git a/app-emacs/howm/howm-1.3.9.1.ebuild b/app-emacs/howm/howm-1.3.9.1.ebuild
new file mode 100644
index 000000000000..3103b8b50fa9
--- /dev/null
+++ b/app-emacs/howm/howm-1.3.9.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Note-taking tool on Emacs"
+HOMEPAGE="http://howm.sourceforge.jp/"
+SRC_URI="http://howm.sourceforge.jp/a/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf --with-docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake -j1 </dev/null
+}
+
+src_install() {
+ emake -j1 \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ LISPDIR="${EPREFIX}${SITELISP}/${PN}" \
+ install </dev/null
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "site-gentoo.el does no longer define global keybindings for howm."
+ elog "Add the following line to ~/.emacs for the previous behaviour:"
+ elog " (require 'howm)"
+}
diff --git a/app-emacs/howm/howm-1.3.9.2.ebuild b/app-emacs/howm/howm-1.3.9.2.ebuild
new file mode 100644
index 000000000000..3103b8b50fa9
--- /dev/null
+++ b/app-emacs/howm/howm-1.3.9.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Note-taking tool on Emacs"
+HOMEPAGE="http://howm.sourceforge.jp/"
+SRC_URI="http://howm.sourceforge.jp/a/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf --with-docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake -j1 </dev/null
+}
+
+src_install() {
+ emake -j1 \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ LISPDIR="${EPREFIX}${SITELISP}/${PN}" \
+ install </dev/null
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "site-gentoo.el does no longer define global keybindings for howm."
+ elog "Add the following line to ~/.emacs for the previous behaviour:"
+ elog " (require 'howm)"
+}
diff --git a/app-emacs/howm/metadata.xml b/app-emacs/howm/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/howm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>