summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-23 11:03:23 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-23 11:17:36 +0100
commitb9b7134c3cadf66f9ae729014a70a0847d3785f1 (patch)
tree7cc345cb5f7923f1313d2c6f6b734792ee9f54b9 /app-emacs/pandoc-mode
parentapp-emacs/ebib: drop old 2.49 (diff)
downloadgentoo-b9b7134c3cadf66f9ae729014a70a0847d3785f1.tar.gz
gentoo-b9b7134c3cadf66f9ae729014a70a0847d3785f1.tar.bz2
gentoo-b9b7134c3cadf66f9ae729014a70a0847d3785f1.zip
app-emacs/pandoc-mode: bump to 2.34.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/pandoc-mode')
-rw-r--r--app-emacs/pandoc-mode/Manifest1
-rw-r--r--app-emacs/pandoc-mode/pandoc-mode-2.34.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/pandoc-mode/Manifest b/app-emacs/pandoc-mode/Manifest
index d5ac95ee3120..3bb90d35839b 100644
--- a/app-emacs/pandoc-mode/Manifest
+++ b/app-emacs/pandoc-mode/Manifest
@@ -1,2 +1,3 @@
DIST pandoc-mode-2.32.tar.gz 97596 BLAKE2B 2a1c8a6080fbba1cf278d78f9dbe4e6824daed52ad6422378d6b5c00fd4ec9466391474fdbaad5f1cd96d89080c24968b33c0911cb5f834ddd64dc1339b78c01 SHA512 6717bf238a9f71acce8135d5fa0542c23f2b48d78415f92dda2ef58aa0355ca0fe900e1015d0da674abf7780ed614bd7d4414519bf6d0d7f5aee7e3b7a7f447f
DIST pandoc-mode-2.33.tar.gz 97645 BLAKE2B d6bd6fa713f5b8d50bdaa8df880099a4fe670353ba98ac7d63d0fc6b5d7b4398a585a43c34d04e94fc794de666a45bff8b11a8a850d581553a64b5b2d5db5178 SHA512 a7d6ed18bd5cad3a70f0b15aedf4d70de723318ec082d60ad543b438d9fca19f04c91d5829fa431578089e03b00f365b9c939ea6f8c09367ae510ddd3fa8fc67
+DIST pandoc-mode-2.34.1.tar.gz 97859 BLAKE2B 0bbf42197708b4b908c7603d416ae2e1cd0974877c504636ac8e763fbfb4c6eb9dce0b6ff2565b1b979e99cad0e5ffbba4e73181a234010e076bf22c9bea1579 SHA512 f7a8b52aaea89fdb8da4c90b1c970ef42da8ca58c2e78c20e4e6716d4117da1b1492f2be64aa85306b4bdf889ecfefc83086ade0abcf25b907f8bd5b2545a9f6
diff --git a/app-emacs/pandoc-mode/pandoc-mode-2.34.1.ebuild b/app-emacs/pandoc-mode/pandoc-mode-2.34.1.ebuild
new file mode 100644
index 000000000000..0c83b4200507
--- /dev/null
+++ b/app-emacs/pandoc-mode/pandoc-mode-2.34.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs minor mode for interacting with Pandoc"
+HOMEPAGE="https://joostkremers.github.io/pandoc-mode/
+ https://github.com/joostkremers/pandoc-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joostkremers/${PN}.git"
+else
+ SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="
+ app-emacs/dash
+ app-emacs/hydra
+"
+RDEPEND="
+ ${BDEPEND}
+ virtual/pandoc
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ doinfo "${PN}.info"
+}