summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-17 22:32:24 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-17 22:53:19 +0100
commit569ef8bc4daad57eff8ec29e1e425989dfdae5d2 (patch)
tree909c7a93c85f340a2be93fd547e7720643abda8c /app-emacs
parentapp-emacs/eldev: bump to 1.9.1 (diff)
downloadgentoo-569ef8bc4daad57eff8ec29e1e425989dfdae5d2.tar.gz
gentoo-569ef8bc4daad57eff8ec29e1e425989dfdae5d2.tar.bz2
gentoo-569ef8bc4daad57eff8ec29e1e425989dfdae5d2.zip
app-emacs/modus-themes: bump to 4.4.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/modus-themes/Manifest1
-rw-r--r--app-emacs/modus-themes/modus-themes-4.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/modus-themes/Manifest b/app-emacs/modus-themes/Manifest
index 244469053d51..39765f51c6c2 100644
--- a/app-emacs/modus-themes/Manifest
+++ b/app-emacs/modus-themes/Manifest
@@ -1 +1,2 @@
DIST modus-themes-4.3.0.tar.gz 329115 BLAKE2B 343070beb66fece35000abe4ae2d4b38c4e06f40a79ed6b12586ed37d39d4c9b67f930869ea8dab51bba84936ed55a8280ea838c4f3be235f95b28d9ec89ffc2 SHA512 3fd24e1b94ec6f3391568f3b92c9224372729494d7edd3ca51167f1a410038f046aaa7fcc8bda8a46ac0a1da5f0509fa9c8dbe49ddfb1aa26b64dcc11ee7ee77
+DIST modus-themes-4.4.0.tar.gz 337719 BLAKE2B 32e189aae2c031a8f0588d241d42c4420120ee45d7a409e4019917f1bb268433d44362305150cba49c7f24a9620ad7208c85d355a383ed684b737e52518e164e SHA512 cf20de778f43225a9412aead302ed373ac078695ec06494a39046bb9ae9e1104408dc282e34582463cc8ea7a5ad389b1ed12b176561271292cc3b50528d71a0e
diff --git a/app-emacs/modus-themes/modus-themes-4.4.0.ebuild b/app-emacs/modus-themes/modus-themes-4.4.0.ebuild
new file mode 100644
index 000000000000..e3ecfc9b2f8f
--- /dev/null
+++ b/app-emacs/modus-themes/modus-themes-4.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Highly accessible themes for GNU Emacs"
+HOMEPAGE="https://github.com/protesilaos/modus-themes/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}