summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-10 20:01:58 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-10 20:16:41 +0200
commit6927e5860afbd9a3c280d713e3b8a0bd09a4f1ee (patch)
treefb92d9694c0d137e29922faf5c460e88b40ab8f6 /app-emacs
parentapp-emacs/transient: sync live 9999 version (diff)
downloadgentoo-6927e5860afbd9a3c280d713e3b8a0bd09a4f1ee.tar.gz
gentoo-6927e5860afbd9a3c280d713e3b8a0bd09a4f1ee.tar.bz2
gentoo-6927e5860afbd9a3c280d713e3b8a0bd09a4f1ee.zip
app-emacs/magit: bump to 4.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/magit/Manifest1
-rw-r--r--app-emacs/magit/magit-4.0.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/magit/Manifest b/app-emacs/magit/Manifest
index ea4282ae2bbd..93f7dc3e5b0e 100644
--- a/app-emacs/magit/Manifest
+++ b/app-emacs/magit/Manifest
@@ -1 +1,2 @@
DIST magit-3.3.0.50_p20240520.tar.gz 673945 BLAKE2B d61fb8c566de2bc6a2c4109d787808be76fa33d994adeb97b3d472c9c2da929aa55cf6b81f9cc2055e46d5860aa0d9ddc37080a1b2be06984b3831382031b12b SHA512 53203cdc8bc291302ee35aabe6e4d32e0c0de5bb411ab013d112bcd3d934a221c34f42d6ebccea9d33335d53415f75588468c23668cbbf57851dc61de505fffb
+DIST magit-4.0.0.tar.gz 676167 BLAKE2B 2adc7388cddc5230615344b3340ae181feaea1e6c174970e11a5d6f6795ecb32581dc12448c1bdfa6ec4144cc4118ace70049ff264a2c29f084cf90aa3f56d69 SHA512 c42dfe78f1f1c5f6cc732a566b820362993763ada7186d1a76ba0deedf7bd91415d502984e4afd6e958ea237b3f351c718a9e588f9734d7afc186793432229f0
diff --git a/app-emacs/magit/magit-4.0.0.ebuild b/app-emacs/magit/magit-4.0.0.ebuild
new file mode 100644
index 000000000000..19d51447f288
--- /dev/null
+++ b/app-emacs/magit/magit-4.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/
+ https://github.com/magit/magit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/${P}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../README.md ../docs/AUTHORS.md ../docs/RelNotes )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ >=app-emacs/dash-2.19.1
+ >=app-emacs/transient-0.7.4
+ >=app-emacs/with-editor-3.4.1
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+RDEPEND+="
+ >=dev-vcs/git-2.44.2
+"
+
+src_prepare() {
+ default
+
+ echo "(setq ${PN}-version \"${PV}\")" > ./${PN}-version.el || die
+}