summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-26 18:07:36 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-26 18:09:33 +0200
commit98be053e1ac0cb62a61bb43e139013f52f531f82 (patch)
tree4a7af5c6d7573d2fe339cf97f670a808411c92e9 /app-emacs
parentapp-emacs/buttercup: remove elisp autoload file; minor fixes (diff)
downloadgentoo-98be053e1ac0cb62a61bb43e139013f52f531f82.tar.gz
gentoo-98be053e1ac0cb62a61bb43e139013f52f531f82.tar.bz2
gentoo-98be053e1ac0cb62a61bb43e139013f52f531f82.zip
app-emacs/buttercup: bump to 1.25
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/buttercup/Manifest1
-rw-r--r--app-emacs/buttercup/buttercup-1.25.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/buttercup/Manifest b/app-emacs/buttercup/Manifest
index 07dbcd1e884b..361966f289e9 100644
--- a/app-emacs/buttercup/Manifest
+++ b/app-emacs/buttercup/Manifest
@@ -1 +1,2 @@
DIST buttercup-1.24.tar.gz 85337 BLAKE2B fb40d0899f68aff5f2fdb989b2c0e42005e6667ecfe8a4ca806ddb4139f497f0eed5328ba6407136b757a0f13bc6ec5ee488792da3de1e84edba394a781c410c SHA512 0a436f5e5bcf386a3675ef281ac6c9f0125917058de88a5557d879004bbf7cd4298086aa3fb86f2bd807f46c166b0fb02e248cc485878891293147656525f8ca
+DIST buttercup-1.25.tar.gz 86763 BLAKE2B ccf7ba797517710e66b666cc121766d29886e0e1a8fd5ad63cb8b5fa4ee2d2a0d2644cd413c1095f37b1ba60467c012e507230787e1daaca3e869a4072e61bb4 SHA512 1eb45485fb1de638837da4d97f6043a64e97d167c8c130d9c5ba6ff67a5e0bcae272c8247779ab1c9427668468a3b94e91af07426b5465a7c3f9c54433a0433e
diff --git a/app-emacs/buttercup/buttercup-1.25.ebuild b/app-emacs/buttercup/buttercup-1.25.ebuild
new file mode 100644
index 000000000000..aaf465a347d8
--- /dev/null
+++ b/app-emacs/buttercup/buttercup-1.25.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="24.3"
+
+inherit elisp
+
+DESCRIPTION="Behaviour-driven Elisp testing"
+HOMEPAGE="https://github.com/jorgenschaefer/emacs-buttercup"
+SRC_URI="https://github.com/jorgenschaefer/emacs-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( docs/{running,writing}-tests.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l buttercup \
+ -f buttercup-run-discover || die "tests failed"
+}
+
+src_install() {
+ elisp_src_install
+ dobin bin/${PN}
+}