summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-04 11:47:37 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-04 11:53:25 +0200
commitc7d1419e262e1b8a4244315fe6e972adec42943f (patch)
tree8fda4176c76d65bd65c90b076b49fa59cd22c7e4 /app-emacs
parentmedia-sound/musescore: updated patch in live ebuild (diff)
downloadgentoo-c7d1419e262e1b8a4244315fe6e972adec42943f.tar.gz
gentoo-c7d1419e262e1b8a4244315fe6e972adec42943f.tar.bz2
gentoo-c7d1419e262e1b8a4244315fe6e972adec42943f.zip
app-emacs/diff-hl: bump to 1.10.0
Closes: https://bugs.gentoo.org/937217 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/diff-hl/Manifest1
-rw-r--r--app-emacs/diff-hl/diff-hl-1.10.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/diff-hl/Manifest b/app-emacs/diff-hl/Manifest
index c593f6e9ef4c..524198366621 100644
--- a/app-emacs/diff-hl/Manifest
+++ b/app-emacs/diff-hl/Manifest
@@ -1 +1,2 @@
+DIST diff-hl-1.10.0.tar.gz 243449 BLAKE2B 64d091f3d9a1c6956f3d1d579299fd5ca3863053990cc03ae0318acc70ce88018fc4721f48abd18a30abfc410bf63f5154993d07d35fad431f0ea48892407ed0 SHA512 686d424fccec19bce4880e967a2ad3f27c8ea457a0e5f0d56eae0c46bd4c8df9951443115a2ee2614301cf5dbbc862f8233f00d3c8be0aa3c8335d1f5bbc7432
DIST diff-hl-1.9.2.tar.gz 242052 BLAKE2B 03a4daa14d0a80dbbe61b3e2ef853416750eb59806da2c2c7ba07fd5403f78a7566c124e9559733a78ab751562cf462db7702985f36d6375765efcc3fa6b5697 SHA512 067c902632bc70f10b201f9be38ee14c87a9026a1ac7076642d63ca421de287bf47ccee2e47a323c164672a718a5964e940b86f8330f5be35cfd90bff3ecf1a1
diff --git a/app-emacs/diff-hl/diff-hl-1.10.0.ebuild b/app-emacs/diff-hl/diff-hl-1.10.0.ebuild
new file mode 100644
index 000000000000..841fee81ceca
--- /dev/null
+++ b/app-emacs/diff-hl/diff-hl-1.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Highlight uncommitted changes, jump between and revert them selectively"
+HOMEPAGE="https://github.com/dgutov/diff-hl/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/dgutov/${PN}.git"
+else
+ SRC_URI="https://github.com/dgutov/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( dev-vcs/git )
+"
+
+DOCS=( README.md screenshot{,-dired,-margin}.png )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ebegin "Creating a git repository for tests"
+ git init "${S}" --initial-branch="master" &&
+ git add "${S}" &&
+ git config --local user.email "test@test" &&
+ git config --local user.name "test" &&
+ git commit --message "test" --quiet
+ eend "${?}" || die
+
+ emake EMACS="${EMACS} ${EMACSFLAGS}" test
+}