summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-03 13:09:20 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-03 14:00:07 +0100
commitd7bf65a82449e8ba73967fa7a69f828cb72997d4 (patch)
treea9bbd830ddaeedce5c0b8ef9c156d5996acdec47 /app-emacs
parentapp-emacs/cider: bump to 1.13.1 (diff)
downloadgentoo-d7bf65a82449e8ba73967fa7a69f828cb72997d4.tar.gz
gentoo-d7bf65a82449e8ba73967fa7a69f828cb72997d4.tar.bz2
gentoo-d7bf65a82449e8ba73967fa7a69f828cb72997d4.zip
app-emacs/cmake-mode: bump to 3.28.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/cmake-mode/Manifest1
-rw-r--r--app-emacs/cmake-mode/cmake-mode-3.28.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/cmake-mode/Manifest b/app-emacs/cmake-mode/Manifest
index 5846714671d3..02857398d93f 100644
--- a/app-emacs/cmake-mode/Manifest
+++ b/app-emacs/cmake-mode/Manifest
@@ -1 +1,2 @@
DIST cmake-3.28.1.tar.gz 11065923 BLAKE2B 7c6d3876633024b8a22dd6aca078e4bd7649c18a810ada68378435e9cfc30878b89529dc69e6e2dcecd114c9686fe6ce937fa5587e47f00128504349cecb967b SHA512 62693c423dd46d252d046662ac34cf9c927b7ec23c213c6b5cd1683636b8bbb5326698af1e7f851f3c01fe3f14dd769b9a8bd405f8f9e73e6d8defae7517cbcb
+DIST cmake-3.28.2.tar.gz 11067468 BLAKE2B 59941152814af141cdbea5a649d809cb86edaf2f460a493278872cb0dcff45ea2c68d7e783cd4bc4b369bf4d41175aee6d49a4e2b983877700be933340f6596b SHA512 225f6d3eb56d41c449a32f7c3e0f8f3ffafbbf45474e29ad86e965a87f8d95e55e87affc62ef0a7b25c9fb070c6fca08e9838539e5f7011dc3ee83787025151b
diff --git a/app-emacs/cmake-mode/cmake-mode-3.28.2.ebuild b/app-emacs/cmake-mode/cmake-mode-3.28.2.ebuild
new file mode 100644
index 000000000000..e6ca0450dffd
--- /dev/null
+++ b/app-emacs/cmake-mode/cmake-mode-3.28.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_P="${P/-mode}"
+MY_P="${MY_P/_/-}"
+
+DESCRIPTION="GNU Emacs mode for handling CMake build files"
+HOMEPAGE="https://cmake.org/"
+SRC_URI="https://cmake.org/files/v$(ver_cut 1-2)/${MY_P}.tar.gz"
+S="${WORKDIR}/${P/-mode}/Auxiliary"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !dev-build/cmake[emacs(-)]
+"
+
+DOCS=()
+SITEFILE="50${PN/-mode}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}