summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-11-30 15:03:06 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-11-30 15:03:06 +0100
commit1fd5b164fa298a2f5cd6160afd3068eced80b526 (patch)
tree4ad3e92a19fc1f08808a8457c5342d569fbd8f27 /app-emulation/cadvisor/cadvisor-0.28.2.ebuild
parentmedia-libs/x265: bump to 2.6 (diff)
downloadgentoo-1fd5b164fa298a2f5cd6160afd3068eced80b526.tar.gz
gentoo-1fd5b164fa298a2f5cd6160afd3068eced80b526.tar.bz2
gentoo-1fd5b164fa298a2f5cd6160afd3068eced80b526.zip
app-emulation/cadvisor: Initial version
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-emulation/cadvisor/cadvisor-0.28.2.ebuild')
-rw-r--r--app-emulation/cadvisor/cadvisor-0.28.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emulation/cadvisor/cadvisor-0.28.2.ebuild b/app-emulation/cadvisor/cadvisor-0.28.2.ebuild
new file mode 100644
index 000000000000..25f12f419338
--- /dev/null
+++ b/app-emulation/cadvisor/cadvisor-0.28.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/google/cadvisor"
+
+inherit user golang-build golang-vcs-snapshot
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Analyzes resource usage and performance characteristics of running containers"
+
+HOMEPAGE="https://github.com/google/cadvisor"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+}