summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-07-03 19:48:35 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-07-03 19:48:35 +0200
commitf0f5f7631bbe2714d71eb16c8c7c000c07a551f4 (patch)
treeb67433fecff129e5cefb3b5231f75453faebaae4 /app-emulation/containerd
parentdev-ml/ocaml-containers: backport upstream test build fix with latest qcheck,... (diff)
downloadgentoo-f0f5f7631bbe2714d71eb16c8c7c000c07a551f4.tar.gz
gentoo-f0f5f7631bbe2714d71eb16c8c7c000c07a551f4.tar.bz2
gentoo-f0f5f7631bbe2714d71eb16c8c7c000c07a551f4.zip
app-emulation/containerd: Version bump to 0.2.9
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-0.2.9.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index c818ccf0f8f8..54fc20171b68 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -4,3 +4,4 @@ DIST containerd-0.2.6.tar.gz 1020572 SHA256 a67c4153ac5ae26b9d11daac133b90cba059
DIST containerd-0.2.7.tar.gz 1034541 SHA256 cc46de64a75fa8babe0a85aac987f926870bf84d78040430f95ce478ed195122 SHA512 d0885fa37aaa1110d9312f81102e619ca4ae8d3c39c83c01852fd8618945121596169a1d41017d19ad32ff47b619a2c1c18a3582d290a56f08640412dcfc451a WHIRLPOOL 35748adf2c097dad4c60e48b2eb3389b57e78fc8d3b228f15b0297b5c1d037a77f29118089a5159c1f25baf7e4d7f93f6fc74d3cd2c85164711378e2df6e251d
DIST containerd-0.2.8.tar.gz 1034518 SHA256 f002d4d93a86cd3a0c9e7d9d71455a94790302daab1e51dd2dd53e7f0ba4d217 SHA512 a8c0b9faa9bf225be315067aa634ee366c8d78a137dddade2ad09160ecd8f89d487fdce896efd73bedcd6d8c97e20f746ba949a13901c38977a40dbb558339d8 WHIRLPOOL 99058822f80d37e8a96968ae26cf00c33c8ed78fffeff9f2d07a2c25c76439ab44c92ce333712f6749787a04b65c54b112511d66c97cfcce35a5d5cf954ac2f4
DIST containerd-0.2.8_p20170504.tar.gz 1231053 SHA256 6316ecefe43c89ddafd31608f6d21aeec250f498b27c194551bde3679e765865 SHA512 6b5fc4845c560239e197c93620f1b836972563f24c8a595ff82f6798c372c5b9a7a6be6dc52aa443d72b61108723d56a67884ff464f666085b3af28424e56136 WHIRLPOOL 2982a405aa82c28e7498e54d42d29557b6024ed411537c4b2084f8574111511f4e5cb751ac18b025919047aa45933bdd28171b871826f87cfa004d53503cfbb4
+DIST containerd-0.2.9.tar.gz 1228977 SHA256 2360fec91d40e4e93757f964f07c74e35b6bfe838252b1cc814a176e1cd1c604 SHA512 6f0de476668e6b86a0cd5e1ea0f6dac24e0e68fe2dd52b8915dbafa5ffab137a5eea866c216f8184ffa6e4750c7b69bce3d46552e8be283a15ce676ea4356fc8 WHIRLPOOL b9fdd57af3cf39e6a5efdd67f0302ad38d6634d20aa3eb45431d2900f5fbb7dc62d624b07a5028bbb09ae763e07103e37703cf52f3e14e7af72fc2198d9c7876
diff --git a/app-emulation/containerd/containerd-0.2.9.ebuild b/app-emulation/containerd/containerd-0.2.9.ebuild
new file mode 100644
index 000000000000..3849a49ca7a0
--- /dev/null
+++ b/app-emulation/containerd/containerd-0.2.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="cfb82a876ecc11b5ca0977d1733adbe58599088a"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened +seccomp"
+
+DEPEND=""
+RDEPEND=">=app-emulation/docker-runc-1.0.0_rc3_p20170607
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_compile() {
+ local options=( $(usex seccomp "seccomp" '') )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd* bin/ctr
+}