summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <g.braeunlich@disroot.org>2019-02-18 11:31:44 +0100
committerZac Medico <zmedico@gentoo.org>2019-02-18 23:10:48 -0800
commitfb9c5140920894bf268a28cdfcf5b3cb611dc278 (patch)
treea0e41b36061bd0324125577345f79e2098713e01 /app-emulation/slirp4netns/slirp4netns-0.3.0_alpha2.ebuild
parentmail-client/thunderbird: amd64 stable wrt bug #678072 (diff)
downloadgentoo-fb9c5140920894bf268a28cdfcf5b3cb611dc278.tar.gz
gentoo-fb9c5140920894bf268a28cdfcf5b3cb611dc278.tar.bz2
gentoo-fb9c5140920894bf268a28cdfcf5b3cb611dc278.zip
app-emulation/slirp4netns: New ebuild
Closes: https://github.com/gentoo/gentoo/pull/11090 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Gerhard Bräunlich <g.braeunlich@disroot.org> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/slirp4netns/slirp4netns-0.3.0_alpha2.ebuild')
-rw-r--r--app-emulation/slirp4netns/slirp4netns-0.3.0_alpha2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/slirp4netns/slirp4netns-0.3.0_alpha2.ebuild b/app-emulation/slirp4netns/slirp4netns-0.3.0_alpha2.ebuild
new file mode 100644
index 000000000000..3dd9a9ad4053
--- /dev/null
+++ b/app-emulation/slirp4netns/slirp4netns-0.3.0_alpha2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="User-mode networking for unprivileged network namespaces"
+HOMEPAGE="https://github.com/rootless-containers/slirp4netns"
+SRC_URI="https://github.com/rootless-containers/slirp4netns/archive/v${PV/_alpha/-alpha.}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+
+S="${WORKDIR}/${P/_alpha/-alpha.}"
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+pkg_postinst() {
+ elog "You need to have the tun kernel module loaded in order to have"
+ elog "slirp4netns working"
+}