summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/xe-guest-utilities/xe-guest-utilities-6.1.0_p1033.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/xe-guest-utilities/xe-guest-utilities-6.1.0_p1033.ebuild')
-rw-r--r--app-emulation/xe-guest-utilities/xe-guest-utilities-6.1.0_p1033.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-emulation/xe-guest-utilities/xe-guest-utilities-6.1.0_p1033.ebuild b/app-emulation/xe-guest-utilities/xe-guest-utilities-6.1.0_p1033.ebuild
new file mode 100644
index 000000000000..21d0af88ef6e
--- /dev/null
+++ b/app-emulation/xe-guest-utilities/xe-guest-utilities-6.1.0_p1033.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils rpm linux-info
+DESCRIPTION="XenServer Virtual Machine Tools"
+HOMEPAGE="http://www.citrix.com/"
+PV_BASE=${PV/_*}
+PV_FULL=${PV/_p/-}
+SRC_URI="http://updates.vmd.citrix.com/XenServer/${PV_BASE}/rhel4x/SRPMS/xe-guest-utilities-${PV_FULL}.src.rpm"
+LICENSE="LGPL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="xenstore"
+DEPEND="app-arch/rpm2targz"
+RDEPEND="
+ !xenstore? ( app-emulation/xen-tools )
+ xenstore? ( !app-emulation/xen-tools )"
+S=${WORKDIR}
+CONFIG_CHECK="~XEN_COMPAT_XENFS ~XENFS"
+QA_PREBUILT="usr/bin/xenstore* usr/bin/xeninfo"
+
+src_unpack() {
+ rpm_src_unpack ${A}
+ # Upstream includes xenstore-sources.tar.bz2
+ # but it is NOT the complete source :-(
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-6.2.0_p1120-Guest-Attributes.patch
+ epatch "${FILESDIR}"/${PN}-6.2.0_p1120-Linux-Distribution.patch
+}
+
+src_install() {
+ newinitd "${FILESDIR}/xe-daemon.initd" xe-daemon
+ dosbin xe-daemon
+ dosbin xe-linux-distribution
+ dosbin xe-update-guest-attrs
+ insinto /lib/udev/rules.d
+ newins xen-vcpu-hotplug.rules 10-xen-vcpu-hotplug.rules
+
+ if use xenstore; then
+ dobin usr/bin/xeninfo
+ dobin usr/bin/xenstore
+ dobin usr/bin/xenstore-*
+ fi
+}
+
+pkg_postinst() {
+ if [ ! -e /etc/runlevels/boot/xe-daemon ]; then
+ elog "To start the xe-daemon automatically by default"
+ elog "you should add it to the boot runlevel :"
+ elog "'rc-update add xe-daemon boot'"
+ elog
+ fi
+}