summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:54:12 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:45 +0100
commitb13af4915683f355f7161bc9792822a3c0df7f19 (patch)
treee63829d696f9331897156fd4034555dd946e56a9 /app-emulation
parentapp-antivirus/clamav: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-b13af4915683f355f7161bc9792822a3c0df7f19.tar.gz
gentoo-b13af4915683f355f7161bc9792822a3c0df7f19.tar.bz2
gentoo-b13af4915683f355f7161bc9792822a3c0df7f19.zip
app-emulation/flannel: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/flannel/flannel-0.11.0.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/app-emulation/flannel/flannel-0.11.0.ebuild b/app-emulation/flannel/flannel-0.11.0.ebuild
index 2ba1cf0dfa67..9ddf9cc7bedf 100644
--- a/app-emulation/flannel/flannel-0.11.0.ebuild
+++ b/app-emulation/flannel/flannel-0.11.0.ebuild
@@ -49,3 +49,7 @@ src_install() {
systemd_dounit "${FILESDIR}/flanneld.service"
dodoc README.md
}
+
+pkg_postinst() {
+ tmpfiles_process flannel.conf
+}