summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2022-11-19 16:38:07 +0200
committerViorel Munteanu <ceamac@gentoo.org>2022-11-20 10:18:42 +0200
commitd1e553ee971b105c5bfe7835d693df82d90044f6 (patch)
tree81bf48bc53ebad33402ce0dc669744ef22c511ea /app-emulation
parentapp-emulation/virtualbox-guest-additions: add 7.0.4 (diff)
downloadgentoo-d1e553ee971b105c5bfe7835d693df82d90044f6.tar.gz
gentoo-d1e553ee971b105c5bfe7835d693df82d90044f6.tar.bz2
gentoo-d1e553ee971b105c5bfe7835d693df82d90044f6.zip
app-emulation/virtualbox: fix regression with USE="headless sdl"
Bug: https://bugs.gentoo.org/678534 Closes: https://github.com/gentoo/gentoo/pull/28229 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virtualbox/virtualbox-7.0.2.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-emulation/virtualbox/virtualbox-7.0.2.ebuild b/app-emulation/virtualbox/virtualbox-7.0.2.ebuild
index 1a1bd3355268..bc613d5df1fa 100644
--- a/app-emulation/virtualbox/virtualbox-7.0.2.ebuild
+++ b/app-emulation/virtualbox/virtualbox-7.0.2.ebuild
@@ -201,6 +201,11 @@ pkg_pretend() {
einfo "USE=\"headless\", this build will not include any X11/Qt frontend."
fi
+ if use headless && use sdl; then
+ einfo "You selected USE=\"headless sdl\", defaulting to"
+ einfo "USE=\"headless\", this build will not include SDL."
+ fi
+
if ! use opengl; then
einfo "No USE=\"opengl\" selected, this build will lack"
einfo "the OpenGL feature."
@@ -289,7 +294,7 @@ src_prepare() {
CFLAGS=${CFLAGS}
EOF
- if use sdl; then
+ if ! use headless && use sdl; then
echo -e "\nVBOX_WITH_VBOXSDL=1" >> LocalConfig.kmk || die
fi