summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-18 23:22:31 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-18 23:41:14 +0100
commitdd445b3181973262fa41a591286ec101c9cf486a (patch)
tree89a97373bcdf45bc6370ce8ed2ba6475612b1ac9 /app-emulation
parentnet-wireless/wepattack: update jtr deps (diff)
downloadgentoo-dd445b3181973262fa41a591286ec101c9cf486a.tar.gz
gentoo-dd445b3181973262fa41a591286ec101c9cf486a.tar.bz2
gentoo-dd445b3181973262fa41a591286ec101c9cf486a.zip
app-emulation/cloud-init: 18.4-r1 → 18.5
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cloud-init/Manifest1
-rw-r--r--app-emulation/cloud-init/cloud-init-18.5.ebuild90
-rw-r--r--app-emulation/cloud-init/files/18.5-fix-invalid-string-format.patch46
3 files changed, 137 insertions, 0 deletions
diff --git a/app-emulation/cloud-init/Manifest b/app-emulation/cloud-init/Manifest
index 6a289ecfa8ca..4f2aa6f1599a 100644
--- a/app-emulation/cloud-init/Manifest
+++ b/app-emulation/cloud-init/Manifest
@@ -1,2 +1,3 @@
DIST cloud-init-17.2.tar.gz 810821 BLAKE2B df1a7c1ed1fc48a7801a53bd89839d963debca6abf7f892d61bf7ec9222ab33bf78221e65d79028e0445cac4c5fe1e0c1620d49aea26c036ee17933d9c1893f5 SHA512 ad1c7f6ca9762b70a1f06a6b538032a7de0c5371fd792260d5959df113f4f51509d184b2207ffa23b41f395c1903d551d66aaf2a2ad60af3594cf1f18d1e4a38
DIST cloud-init-18.4.tar.gz 965112 BLAKE2B 2879aafedea877e4e406a5e837d100ba65e40c62660621f606e7a189af7b1ec8d98ba2c02ae5d253a0b4587502d3a636dec5c2772c968a9037b47e62a05656b4 SHA512 730aca6406f652f55afc2dd50c49eb6708584e0a96715606bcba05cb7f40e47c256faff1f9748f04674a8f941ec9435801c9ed2ac79adec8a6ef167d6b195103
+DIST cloud-init-18.5.tar.gz 990381 BLAKE2B 0dbbd5b2402d3a7742c46f8a37b0ea31f40ac16bdbfe49dca0056ab8f90c47dbf26e6d3f40f34275caf5102d0b9b8be4e2c28bfc2276e85a5aad11af20b08979 SHA512 f89ee636922e33b5b2dcb5230763404fbeee148e28b8f61bf5b2f1f07000f960f9d38545dfb7bcbe9afb8253f77d66c94b39e9a159715b44a440a7cbe1fe1aeb
diff --git a/app-emulation/cloud-init/cloud-init-18.5.ebuild b/app-emulation/cloud-init/cloud-init-18.5.ebuild
new file mode 100644
index 000000000000..c4ff15cbfd9b
--- /dev/null
+++ b/app-emulation/cloud-init/cloud-init-18.5.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cloud instance initialisation magic"
+HOMEPAGE="https://launchpad.net/cloud-init"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${CDEPEND}
+ >=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ net-analyzer/macchanger
+ sys-apps/iproute2
+ sys-fs/growpart
+ virtual/logger
+"
+
+PATCHES=(
+ # Fix Gentoo support
+ # https://code.launchpad.net/~gilles-dartiguelongue/cloud-init/+git/cloud-init/+merge/358777
+ "${FILESDIR}"/${PN}-18.4-fix-packages-module.patch
+ "${FILESDIR}"/${PN}-18.4-gentoo-support-upstream-templates.patch
+ "${FILESDIR}"/18.4-fix-filename-for-storing-locale.patch
+ "${FILESDIR}"/18.4-fix-update_package_sources-function.patch
+ "${FILESDIR}"/18.4-add-support-for-package_upgrade.patch
+ # From master
+ "${FILESDIR}"/${PV}-fix-invalid-string-format.patch
+)
+
+src_prepare() {
+ # Fix location of documentation installation
+ sed -i "s:USR + '/share/doc/cloud-init:USR + '/share/doc/${PF}:" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Do not use Makefile target as it does not setup environment correclty
+ esetup.py nosetests -v --where cloudinit --where tests/unittests || die
+}
+
+python_install() {
+ distutils-r1_python_install --init-system=sysvinit_openrc,systemd --distro gentoo
+}
+
+python_install_all() {
+ keepdir /etc/cloud
+
+ distutils-r1_python_install_all
+
+ # installs as non-executable
+ chmod +x "${D}"/etc/init.d/*
+}
+
+pkg_postinst() {
+ elog "cloud-init-local needs to be run in the boot runlevel because it"
+ elog "modifies services in the default runlevel. When a runlevel is started"
+ elog "it is cached, so modifications that happen to the current runlevel"
+ elog "while you are in it are not acted upon."
+}
diff --git a/app-emulation/cloud-init/files/18.5-fix-invalid-string-format.patch b/app-emulation/cloud-init/files/18.5-fix-invalid-string-format.patch
new file mode 100644
index 000000000000..42030f57dc45
--- /dev/null
+++ b/app-emulation/cloud-init/files/18.5-fix-invalid-string-format.patch
@@ -0,0 +1,46 @@
+From 5b065316113b97aadb43e63cc31bb8639f6a6376 Mon Sep 17 00:00:00 2001
+From: Scott Moser <smoser@ubuntu.com>
+Date: Fri, 14 Dec 2018 03:24:26 +0000
+Subject: [PATCH] Update to pylint 2.2.2.
+
+The tip-pylint tox target correctly reported the invalid use of
+string formatting. The change here is to:
+
+a.) Fix the error that was caught.
+b.) move to pylint 2.2.2 for the default 'pylint' target.
+---
+ cloudinit/sources/DataSourceAzure.py | 4 ++--
+ tox.ini | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/cloudinit/sources/DataSourceAzure.py b/cloudinit/sources/DataSourceAzure.py
+index e076d5dc..46efca4a 100644
+--- a/cloudinit/sources/DataSourceAzure.py
++++ b/cloudinit/sources/DataSourceAzure.py
+@@ -980,8 +980,8 @@ def read_azure_ovf(contents):
+ raise NonAzureDataSource("No LinuxProvisioningConfigurationSet")
+ if len(lpcs_nodes) > 1:
+ raise BrokenAzureDataSource("found '%d' %ss" %
+- ("LinuxProvisioningConfigurationSet",
+- len(lpcs_nodes)))
++ (len(lpcs_nodes),
++ "LinuxProvisioningConfigurationSet"))
+ lpcs = lpcs_nodes[0]
+
+ if not lpcs.hasChildNodes():
+diff --git a/tox.ini b/tox.ini
+index 2fb3209d..d983348b 100644
+--- a/tox.ini
++++ b/tox.ini
+@@ -21,7 +21,7 @@ setenv =
+ basepython = python3
+ deps =
+ # requirements
+- pylint==1.8.1
++ pylint==2.2.2
+ # test-requirements because unit tests are now present in cloudinit tree
+ -r{toxinidir}/test-requirements.txt
+ commands = {envpython} -m pylint {posargs:cloudinit tests tools}
+--
+2.20.0
+