summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-12 18:22:55 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-17 21:39:09 +0100
commit11b4249df9a07f93988a3007baca3cfd1f0fecaa (patch)
treec422cc47433ba95fb08b535de0aade8983db1688 /app-eselect/eselect-python/eselect-python-99999999.ebuild
parentdev-lang/python-exec: Bump to 2.1 (diff)
downloadgentoo-11b4249df9a07f93988a3007baca3cfd1f0fecaa.tar.gz
gentoo-11b4249df9a07f93988a3007baca3cfd1f0fecaa.tar.bz2
gentoo-11b4249df9a07f93988a3007baca3cfd1f0fecaa.zip
app-eselect/eselect-python: Bump to 20151117
The new version no longer alters executable symlinks but instead replaces all executables with python-exec wrappers, relying on changes done in revbump of all dev-lang/python versions. Furthermore, the choice of split python[23] interpreters is done in a config file rather than through symlinks.
Diffstat (limited to 'app-eselect/eselect-python/eselect-python-99999999.ebuild')
-rw-r--r--app-eselect/eselect-python/eselect-python-99999999.ebuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/app-eselect/eselect-python/eselect-python-99999999.ebuild b/app-eselect/eselect-python/eselect-python-99999999.ebuild
index 6b16b3d05248..9968e7fac7c4 100644
--- a/app-eselect/eselect-python/eselect-python-99999999.ebuild
+++ b/app-eselect/eselect-python/eselect-python-99999999.ebuild
@@ -2,15 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-# Keep the EAPI low here because everything else depends on it.
-# We want to make upgrading simpler.
+EAPI=5
if [[ ${PV} == "99999999" ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
@@ -21,21 +19,25 @@ LICENSE="GPL-2"
SLOT="0"
IUSE=""
-RDEPEND=">=app-admin/eselect-1.2.3"
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.1:2
+ !<dev-lang/python-2.7.10-r3:2.7
+ !<dev-lang/python-3.3.5-r3:3.3
+ !<dev-lang/python-3.4.3-r3:3.4
+ !<dev-lang/python-3.5.0-r2:3.5"
-src_unpack() {
- if [[ ${PV} == "99999999" ]] ; then
- git-r3_src_unpack
- cd "${S}"
- eautoreconf
- else
- unpack ${A}
- fi
+src_prepare() {
+ [[ ${PV} == "99999999" ]] && eautoreconf
}
src_install() {
keepdir /etc/env.d/python
emake DESTDIR="${D}" install || die
+
+ local f
+ for f in python{,2,3}{,-config} 2to3 pydoc pyvenv; do
+ dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
+ done
}
pkg_postinst() {