summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-06-12 21:51:48 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-06-18 15:08:16 +0300
commitc5e55284dc8d12980330349476abdabe8e7ba68e (patch)
tree6e0088203c79c47790b29993bd426e0f077ef7be /app-forensics
parentapp-admin/passwordsafe: add 1.17.0 (diff)
downloadgentoo-c5e55284dc8d12980330349476abdabe8e7ba68e.tar.gz
gentoo-c5e55284dc8d12980330349476abdabe8e7ba68e.tar.bz2
gentoo-c5e55284dc8d12980330349476abdabe8e7ba68e.zip
app-forensics/yara: add 4.3.2
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/yara/Manifest1
-rw-r--r--app-forensics/yara/yara-4.3.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-forensics/yara/Manifest b/app-forensics/yara/Manifest
index 4349997ff261..2581c2e37b59 100644
--- a/app-forensics/yara/Manifest
+++ b/app-forensics/yara/Manifest
@@ -1,3 +1,4 @@
DIST yara-4.2.3.tar.gz 1288334 BLAKE2B 4e92570e4dced5c1aa114065d791fc6780ea1281919eb1e908d4181fb5a966137c58d82ae09e8ba18edc69a25d542e3820d8e8de4ac62c0636e273e158086954 SHA512 1df23837d14d3f9f72db901190e7412241514a8914d72b753df32ad8a44c7a49ad8f14941a95de83754e4d1dd0f23d712d8e6a43916343341b92cb1bc66f3c09
DIST yara-4.3.0.tar.gz 2179006 BLAKE2B 97d755c5ffea7fbfc61087f384f4b29543af794af64f86ee2fad10073905fd623480cc1be1c64c8ebf7561c9a8bd323ba5a3fad13044219f110e6a3d04816f36 SHA512 fe239ae2f29fac7b4dbdc0ec84eba057dd4d93c6ae3a53d6bc2a333cc15ed45b1ff5cb896faf02813be667ce191ccbe1d64549552ea4f0834804ad0ec4b29092
DIST yara-4.3.1.tar.gz 2179177 BLAKE2B 071bd2201653b094f828a5ea1ca2dd08fb0e3e8ea0439784bd949fc9ebfeb3c1aa9408581c8808d2d648d988c3aaab676d61605b53446efa12d838898b7ffe16 SHA512 93a2243d54397e76175fa0106451965b7f3a1f1918307c2bae6193f3725b69f60f70c3901a12c1690368f5b37e973a65c63a299624a521d204b12b48d5efe496
+DIST yara-4.3.2.tar.gz 2179265 BLAKE2B cfcc18dbd4c69f5f640ef755a8d4efe5f7ec8e313153955644fbd2adc03d1c73cddc042e95c0c0629fd58780922eb3dc1c72a5ca1bd9ff767a9e3f41f1652c98 SHA512 dc77ec46a30ca2fff33b639166fc554c9c6d9e955642774e23da3ea7dbb25fe154cfd4ef83c9808920193028b9099258a63b3f1b9a66864a1f3905f0a8e8053f
diff --git a/app-forensics/yara/yara-4.3.2.ebuild b/app-forensics/yara/yara-4.3.2.ebuild
new file mode 100644
index 000000000000..3862dff1c51a
--- /dev/null
+++ b/app-forensics/yara/yara-4.3.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A malware identification and classification tool"
+HOMEPAGE="https://virustotal.github.io/yara/"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/VirusTotal/yara.git"
+else
+ SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0/8"
+IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/openssl:=
+ cuckoo? ( dev-libs/jansson:= )
+ magic? ( sys-apps/file:= )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable cuckoo) \
+ $(use_enable magic) \
+ $(use_enable dotnet) \
+ $(use_enable macho) \
+ $(use_enable dex) \
+ $(use_enable test static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ # TODO: Allow tests to work against dyn. lib rather than building
+ # statically just for tests.
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}