summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-21 21:03:53 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-21 17:03:59 -0400
commit045cf49df983cd73f71c2bae2c3c2ec5da47e1dd (patch)
tree5c5f66a00554dc9c35588f959c95423e4d6c5923 /app-i18n/fcitx-chewing
parentapp-i18n/fcitx-chewing: Version bump (0.2.3). (diff)
downloadgentoo-045cf49df983cd73f71c2bae2c3c2ec5da47e1dd.tar.gz
gentoo-045cf49df983cd73f71c2bae2c3c2ec5da47e1dd.tar.bz2
gentoo-045cf49df983cd73f71c2bae2c3c2ec5da47e1dd.zip
app-i18n/fcitx-chewing: Add live ebuild.
Diffstat (limited to 'app-i18n/fcitx-chewing')
-rw-r--r--app-i18n/fcitx-chewing/fcitx-chewing-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chewing/fcitx-chewing-9999.ebuild b/app-i18n/fcitx-chewing/fcitx-chewing-9999.ebuild
new file mode 100644
index 000000000000..cc0804d0cb29
--- /dev/null
+++ b/app-i18n/fcitx-chewing/fcitx-chewing-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-chewing"
+fi
+
+DESCRIPTION="Chinese Chewing input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-chewing"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/libchewing-0.5.0:=
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}