summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/fcitx-sunpinyin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/fcitx-sunpinyin')
-rw-r--r--app-i18n/fcitx-sunpinyin/Manifest2
-rw-r--r--app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-0.4.0.ebuild34
-rw-r--r--app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-0.4.1.ebuild33
-rw-r--r--app-i18n/fcitx-sunpinyin/files/fcitx-sunpinyin-0.4.0-gcc46-compatible.patch27
-rw-r--r--app-i18n/fcitx-sunpinyin/metadata.xml8
5 files changed, 104 insertions, 0 deletions
diff --git a/app-i18n/fcitx-sunpinyin/Manifest b/app-i18n/fcitx-sunpinyin/Manifest
new file mode 100644
index 000000000000..91c1f13dfb72
--- /dev/null
+++ b/app-i18n/fcitx-sunpinyin/Manifest
@@ -0,0 +1,2 @@
+DIST fcitx-sunpinyin-0.4.0.tar.xz 40264 SHA256 366af4123455bd85e5af104ca0368057470079937f79eaa70e58951de4743acc SHA512 53def2f36de0d9517da0d154ae8926075c69a5712bf74a3e5ba5ba6266e2d94152dac77e051473828d98ed6a78d3f10557a8ca2081bf1f799405a4f6a4afb83f WHIRLPOOL 2c92a9d0a9d48eb8e4aca895ccddb91f1d1fbaf137bdc4fe32519cd25a8294be39140d117a0d4d20a5a3fa3c21086bd6edbd44d93fafdf8f885aa7d3d36f9843
+DIST fcitx-sunpinyin-0.4.1.tar.xz 41076 SHA256 7bd0c61a3c821719760bff72c3c114b28e277b87f54dcb61d83e3548b1eb6777 SHA512 7ad9065d86d7bb3ceb6536a0fe3559bf2ba60aebe69e2f07c8dadad1a0a2283a1b85712105c6c2a2bf19b9645c4392204db9c3d1db234618ba7f62ee44eda85c WHIRLPOOL 9339656a5b8cf1359af8f3ceeaa630862a31d4a1089a4b3a738f65c275f0f61d8d06bbe89e496f8922ba4b09b384d96aeac43d7bdfcf21bdaa555c79efd10709
diff --git a/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-0.4.0.ebuild b/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-0.4.0.ebuild
new file mode 100644
index 000000000000..caa149b2374f
--- /dev/null
+++ b/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-0.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Sunpinyin module for fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://fcitx.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.7
+ >app-i18n/sunpinyin-2.0.3"
+DEPEND="${RDEPEND}
+ virtual/libintl"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc46-compatible.patch"
+ epatch_user
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-0.4.1.ebuild b/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-0.4.1.ebuild
new file mode 100644
index 000000000000..b57aef5720c1
--- /dev/null
+++ b/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-0.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Sunpinyin module for fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ >app-i18n/sunpinyin-2.0.3"
+DEPEND="${RDEPEND}
+ virtual/libintl"
+
+src_prepare() {
+ epatch_user
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-sunpinyin/files/fcitx-sunpinyin-0.4.0-gcc46-compatible.patch b/app-i18n/fcitx-sunpinyin/files/fcitx-sunpinyin-0.4.0-gcc46-compatible.patch
new file mode 100644
index 000000000000..42b6b91a3428
--- /dev/null
+++ b/app-i18n/fcitx-sunpinyin/files/fcitx-sunpinyin-0.4.0-gcc46-compatible.patch
@@ -0,0 +1,27 @@
+From f43108d900a2ce7fa52d1c6741fdf41b6747c94c Mon Sep 17 00:00:00 2001
+From: Weng Xuetian <wengxt@gmail.com>
+Date: Sat, 26 Jan 2013 19:56:31 -0500
+Subject: [PATCH] [sunpinyin] gcc46 compatible.
+
+---
+ src/eim.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/eim.cpp b/src/eim.cpp
+index e09521f..c1c898f 100644
+--- a/src/eim.cpp
++++ b/src/eim.cpp
+@@ -49,8 +49,8 @@
+ extern "C" {
+ #endif
+ FCITX_DEFINE_PLUGIN(fcitx_sunpinyin, ime, FcitxIMClass) = {
+- .Create = FcitxSunpinyinCreate,
+- .Destroy = FcitxSunpinyinDestroy
++ FcitxSunpinyinCreate,
++ FcitxSunpinyinDestroy
+ };
+ #ifdef __cplusplus
+ }
+--
+1.7.10
+
diff --git a/app-i18n/fcitx-sunpinyin/metadata.xml b/app-i18n/fcitx-sunpinyin/metadata.xml
new file mode 100644
index 000000000000..7cb952df2e6d
--- /dev/null
+++ b/app-i18n/fcitx-sunpinyin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <upstream>
+ <remote-id type="google-code">fcitx</remote-id>
+ </upstream>
+</pkgmetadata>