summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-05-29 21:59:13 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-05-29 21:59:13 +0900
commit588b2ed0e0e5e2e2b369e331773e6d7a7cd071de (patch)
tree5a238584e80057bc7e9ff13b8346623836dda9d7 /app-i18n/ibus-typing-booster
parentnet-wireless/gnuradio: Support Python 3.12 (diff)
downloadgentoo-588b2ed0e0e5e2e2b369e331773e6d7a7cd071de.tar.gz
gentoo-588b2ed0e0e5e2e2b369e331773e6d7a7cd071de.tar.bz2
gentoo-588b2ed0e0e5e2e2b369e331773e6d7a7cd071de.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-typing-booster')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.8.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index a2ca60fa5737..37e2d65990b6 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,3 +1,4 @@
DIST ibus-typing-booster-2.25.4.tar.gz 12388721 BLAKE2B 3cce75d2524d2b1467d3feb7a0b2067309b88a6b070238f7e7524e426d9556e7624b15c3ff775280abb332ab899ef81fcdc0764e6a61e519947139a5aefc66b4 SHA512 f84111db28d84aa9888b2085ef1351e86c330479c65cf4ff64d87d36001093125c864460a3cb9084ecb430561556f2cf339ee0965a5025c8177a54fec67f4982
DIST ibus-typing-booster-2.25.6.tar.gz 12390887 BLAKE2B 5c0813e16829073e1066117fdf03c2fb713854572e5905f71cb98d51b1f172c8fbd7054fa38c08db7c1e82e1c779258b2934d95508db4914d9e15ade25f61b64 SHA512 212acfc9dcb9d9f3f4405dcfd5e35cf0fec48e41d74539a2a7f9a2b8eb2a1fa6b62919c12b7bbedb9f5ae4904fe463aee2c9801d59eec1389706489e485c54f9
DIST ibus-typing-booster-2.25.7.tar.gz 12389694 BLAKE2B 192618e366b53849e94281ea4d9b98356f820ed6594dcd9ec1c4ddbfacf06d161fe44b4f37c19b3d007515c858b100a2f8b8fd6beb51088a668f269c86feadc6 SHA512 9603b99293e596c958aa2d21e8f0d78b06c6873769b2206c8f5bc225993d53e6af51d493d664d51b8632550e996f714a9ebf0c4ff8f914cd11b4119ac7570203
+DIST ibus-typing-booster-2.25.8.tar.gz 13241387 BLAKE2B 0c5b253f5b7b0b75decce318ccea3c10ca0676fcf2a060e55a0d195dbf591d1fd1aeb319f07e449e1bac2cd22a35e98cce30f6bd55b92edebae6a613d102fb38 SHA512 22581e6e400a93797c2a9b4ff27afe56ab7754624bc229425a34eebb72de8f96b327f360a4d2d0e3f2e80a49005397b555986c09df5463cbbbc011f361e1e336
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.8.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.8.ebuild
new file mode 100644
index 000000000000..95f8e650235b
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.8.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}