summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-04-26 21:59:38 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-04-26 22:02:13 +0900
commitdaa78f70d447c6fcc949cb2bd4fa5790297047d4 (patch)
treebdce7e0f73f9cfa9546466b5b5ac1fc51ce87bf4 /app-i18n/skk-jisyo
parentapp-i18n/skk-jisyo: tidy (diff)
downloadgentoo-daa78f70d447c6fcc949cb2bd4fa5790297047d4.tar.gz
gentoo-daa78f70d447c6fcc949cb2bd4fa5790297047d4.tar.bz2
gentoo-daa78f70d447c6fcc949cb2bd4fa5790297047d4.zip
app-i18n/skk-jisyo: new snapshot
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/skk-jisyo')
-rw-r--r--app-i18n/skk-jisyo/Manifest1
-rw-r--r--app-i18n/skk-jisyo/metadata.xml3
-rw-r--r--app-i18n/skk-jisyo/skk-jisyo-202402.ebuild71
3 files changed, 75 insertions, 0 deletions
diff --git a/app-i18n/skk-jisyo/Manifest b/app-i18n/skk-jisyo/Manifest
index 87ca05478182..dc988c2ffbdb 100644
--- a/app-i18n/skk-jisyo/Manifest
+++ b/app-i18n/skk-jisyo/Manifest
@@ -1 +1,2 @@
DIST skk-jisyo-202005.tar.xz 6836292 BLAKE2B 6d73e6d2e38de178c6683ae447b0ea79054036739b7a01fe386d677cc99556d37f47adf4156e1d571681195b85a2134cac710b12fa08df87e4fe5e5098289119 SHA512 7cc639b307d56d4cb5d04280a003ffa2cfb326f7821d70dddb619e117c1b8358417e44f8137de1b8027ec7f97df8bff8fba845019c015cf8c48ed5d91753155c
+DIST skk-jisyo-202402.tar.xz 7009372 BLAKE2B 4db4be482e537c67861d1f855e34289ce4e7cd790850c012f1a16962196a683170541486468c42fb071a33a498801a2784807793bb49a4a5ca0fa4c805819798 SHA512 72957b207fd28017fc3fbbc43987aa6e7b46b011788036fe96c15172c7934011e3100a45d7e207ebb84cd15f1db667ba366b316f485fecad279f5bd5608920ed
diff --git a/app-i18n/skk-jisyo/metadata.xml b/app-i18n/skk-jisyo/metadata.xml
index a94766977fa6..18319445e66e 100644
--- a/app-i18n/skk-jisyo/metadata.xml
+++ b/app-i18n/skk-jisyo/metadata.xml
@@ -5,4 +5,7 @@
<email>cjk@gentoo.org</email>
<name>Cjk</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">skk-dev/dict</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-i18n/skk-jisyo/skk-jisyo-202402.ebuild b/app-i18n/skk-jisyo/skk-jisyo-202402.ebuild
new file mode 100644
index 000000000000..6f9e6363e3c4
--- /dev/null
+++ b/app-i18n/skk-jisyo/skk-jisyo-202402.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+MY_PN=${PN^^}
+
+DESCRIPTION="Jisyo (dictionary) files for the SKK Japanese-input software"
+HOMEPAGE="https://skk-dev.github.io/dict/"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~hattya/distfiles/${P}.tar.xz"
+
+LICENSE="CC-BY-SA-3.0 GPL-2+ public-domain unicode"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cdb"
+
+DEPEND="app-alternatives/awk
+ cdb? (
+ || (
+ dev-db/tinycdb
+ dev-db/cdb
+ )
+ )"
+RDEPEND=""
+
+DOCS=( ChangeLog{,.{1..3}} committers.md )
+HTML_DOCS=( edict_doc.html )
+
+src_prepare() {
+ rm -f ${MY_PN}.{hukugougo,noregist,notes,pubdic+,requested,unannotated,*wrong*}
+
+ default
+}
+
+cdb_make() {
+ cdbmake "${1}" "${1}.tmp"
+}
+
+tinycdb_make() {
+ cdb -c "${1}"
+}
+
+src_compile() {
+ if use cdb; then
+ local cdbmake=cdb_make f
+ if has_version dev-db/tinycdb; then
+ cdbmake=tinycdb_make
+ fi
+ for f in {,zipcode/}${MY_PN}.*; do
+ LC_ALL=C awk '
+ /^[^;]/ {
+ s = substr($0, index($0, " ") + 1)
+ print "+" length($1) "," length(s) ":" $1 "->" s
+ }
+ END {
+ print ""
+ }
+ ' ${f} | ${cdbmake} ${f}.cdb || die
+ done
+ fi
+}
+
+src_install() {
+ insinto /usr/share/skk
+ doins {,zipcode/}${MY_PN}.*
+
+ einstalldocs
+ docinto zipcode
+ dodoc zipcode/README.md
+}