summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/basenji
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/basenji')
-rw-r--r--app-misc/basenji/Manifest1
-rw-r--r--app-misc/basenji/basenji-1.0.0.ebuild44
-rw-r--r--app-misc/basenji/metadata.xml15
3 files changed, 60 insertions, 0 deletions
diff --git a/app-misc/basenji/Manifest b/app-misc/basenji/Manifest
new file mode 100644
index 000000000000..2f1d0b794749
--- /dev/null
+++ b/app-misc/basenji/Manifest
@@ -0,0 +1 @@
+DIST basenji-1.0.0.tar.gz 642763 SHA256 1a52c351a84ffe05801f1f440bfc9dbf4523136fad0da40d928e6e354c727c1e SHA512 9448545f345138cdef39f872a8bbd60d60a6e8f49a7ea518d58fa69c6711c5ca019d1d0257e26b80b95d5fe12d787ab9b2ed4bf5a76e4f6acccd904cc6fa6084 WHIRLPOOL 315ea82274acbb7e98ac44407fd10fa377940db7b47f37c54ad11806b2e7e0cc1a40568b12bb805316fb2d91cd550a568d305d9072194a7b5d94c392f8b28319
diff --git a/app-misc/basenji/basenji-1.0.0.ebuild b/app-misc/basenji/basenji-1.0.0.ebuild
new file mode 100644
index 000000000000..843742a2e489
--- /dev/null
+++ b/app-misc/basenji/basenji-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit multilib versionator
+
+DESCRIPTION="Basenji is a volume indexing tool designed for easy and fast indexing of volume collections"
+HOMEPAGE="http://launchpad.net/basenji"
+SRC_URI="http://launchpad.net/basenji/trunk/$(get_version_component_range 1-2)/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CDEPEND="dev-dotnet/dbus-sharp
+ dev-dotnet/dbus-sharp-glib
+ dev-dotnet/gio-sharp
+ dev-dotnet/gtk-sharp
+ dev-dotnet/gnome-sharp
+ dev-dotnet/taglib-sharp
+ media-libs/libextractor"
+
+DEPEND="${CDEPEND}"
+
+RDEPEND="${CDEPEND}
+ dev-dotnet/gnome-desktop-sharp
+ sys-fs/udisks"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -i -e "s/-pkg:mono-cairo/-r:Mono.Cairo/" Basenji/Makefile || die "sed failed."
+}
+
+src_configure() {
+ ./configure --prefix="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}
diff --git a/app-misc/basenji/metadata.xml b/app-misc/basenji/metadata.xml
new file mode 100644
index 000000000000..8a8a86733d17
--- /dev/null
+++ b/app-misc/basenji/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Basenji is a volume indexing tool designed for easy and fast indexing of volume collections. It currently supports indexing of removable media such as CDs and USB sticks and stores them as volume objects in a database. After being stored in this database, volumes can be browsed and searched trough for specific files very quickly.
+ </longdescription>
+ <use>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">basenji</remote-id>
+ </upstream>
+</pkgmetadata>