summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/beep
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/beep')
-rw-r--r--app-misc/beep/Manifest2
-rw-r--r--app-misc/beep/beep-1.2.2-r1.ebuild27
-rw-r--r--app-misc/beep/beep-1.3.ebuild29
-rw-r--r--app-misc/beep/files/beep-1.2.2-Makefile.patch26
-rw-r--r--app-misc/beep/files/beep-1.2.2-nosuid.patch33
-rw-r--r--app-misc/beep/metadata.xml5
6 files changed, 122 insertions, 0 deletions
diff --git a/app-misc/beep/Manifest b/app-misc/beep/Manifest
new file mode 100644
index 000000000000..2df976f6f696
--- /dev/null
+++ b/app-misc/beep/Manifest
@@ -0,0 +1,2 @@
+DIST beep-1.2.2.tar.gz 18460 SHA256 5c0445dac43950b7c7c3f235c6fb21f620ab3fd2f3aafaf09896e5730fcf49a1 SHA512 85e2288fc01322ad2b9ad59063ee61cc94edc6b712ef1af2f86bd7e52e08cfaa81a4d8aafd729791eb3e776dbaf8fff7298ccafb758a716a3bdc9a3c385a38e1 WHIRLPOOL 845899b7f2122128833bb0b23a4eb2df576e6239e1c6df80f1abc1d1b5fddb8e80e5a500ba7bfc9638e69e5d2366aea5afdcd15c86d71304c6afe8ba1cf12868
+DIST beep-1.3.tar.gz 19344 SHA256 59acef7a987de5557cefd1a904666cc2691f132929af39e65450b182a581ec2d SHA512 3f71146202208fa0c0cda360d125dd972ea003cf8cd62da21d67eb544c92f7b82640e7ce7c3835cbc65c75909a882edfa54dbd8d8b748d6f243711ea331477fd WHIRLPOOL 23ddc6e456803b82bf84b1022e5eed39488db6f4cd4410e77e55545b3e4c6256979dfc5587367c8206ea069ac4fedc4d5fa81406ea66c6c0c79fb9b428c339c7
diff --git a/app-misc/beep/beep-1.2.2-r1.ebuild b/app-misc/beep/beep-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..3a1cf3038cec
--- /dev/null
+++ b/app-misc/beep/beep-1.2.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils base toolchain-funcs
+
+DESCRIPTION="The advanced PC speaker beeper"
+HOMEPAGE="http://www.johnath.com/beep/"
+SRC_URI="mirror://gentoo/${P}.tar.gz http://www.johnath.com/beep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ppc ppc64 sparc x86"
+IUSE=""
+
+PATCHES=( ${FILESDIR}/${P}-{Makefile,nosuid}.patch )
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_install() {
+ dobin beep
+ fperms 0711 /usr/bin/beep
+ doman beep.1.gz
+ dodoc CHANGELOG CREDITS README
+}
diff --git a/app-misc/beep/beep-1.3.ebuild b/app-misc/beep/beep-1.3.ebuild
new file mode 100644
index 000000000000..f4ef53689687
--- /dev/null
+++ b/app-misc/beep/beep-1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils base toolchain-funcs
+
+DESCRIPTION="The advanced PC speaker beeper"
+HOMEPAGE="http://www.johnath.com/beep/"
+SRC_URI="http://www.johnath.com/beep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+PATCHES=( ${FILESDIR}/${PN}-1.2.2-Makefile.patch )
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_install() {
+ dobin beep
+ fperms 0711 /usr/bin/beep
+ doman beep.1.gz
+ dodoc CHANGELOG CREDITS README
+}
diff --git a/app-misc/beep/files/beep-1.2.2-Makefile.patch b/app-misc/beep/files/beep-1.2.2-Makefile.patch
new file mode 100644
index 000000000000..6497323b9235
--- /dev/null
+++ b/app-misc/beep/files/beep-1.2.2-Makefile.patch
@@ -0,0 +1,26 @@
+--- /var/tmp/portage/app-misc/beep-1.2.2-r1/work/beep-1.2.2/Makefile 2002-03-29 09:37:22.000000000 -0800
++++ /tmp/Makefile 2009-03-27 22:19:18.000000000 -0700
+@@ -1,17 +1,18 @@
+-CC=gcc
+-FLAGS=-Wall
++CC ?= gcc
++LDFLAGS ?=
++CFLAGS ?= -Wall
+ EXEC_NAME=beep
+ INSTALL_DIR=/usr/bin
+ MAN_FILE=beep.1.gz
+-MAN_DIR=/usr/man/man1
++MAN_DIR=/usr/share/man/man1
+
+ default : beep
+
+ clean :
+- rm ${EXEC_NAME}
++ rm -f ${EXEC_NAME}
+
+ beep : beep.c
+- ${CC} ${FLAGS} -o ${EXEC_NAME} beep.c
++ ${CC} ${CFLAGS} ${LDFLAGS} -o ${EXEC_NAME} beep.c
+
+ install :
+ cp ${EXEC_NAME} ${INSTALL_DIR}
diff --git a/app-misc/beep/files/beep-1.2.2-nosuid.patch b/app-misc/beep/files/beep-1.2.2-nosuid.patch
new file mode 100644
index 000000000000..33e6affa9ffb
--- /dev/null
+++ b/app-misc/beep/files/beep-1.2.2-nosuid.patch
@@ -0,0 +1,33 @@
+--- beep.c.orig 2005-07-23 13:37:01.000000000 -0400
++++ beep.c 2005-07-23 14:00:55.000000000 -0400
+@@ -218,22 +218,20 @@
+ int i; /* loop counter */
+
+ /* try to snag the console */
+- if((console_fd = open("/dev/console", O_WRONLY)) == -1) {
+- fprintf(stderr, "Could not open /dev/console for writing.\n");
+- printf("\a"); /* Output the only beep we can, in an effort to fall back on usefulness */
+- perror("open");
+- exit(1);
+- }
++ console_fd = open("/dev/console", O_WRONLY);
+
+ /* Beep */
+ for (i = 0; i < parms.reps; i++) { /* start beep */
+- if(ioctl(console_fd, KIOCSOUND, (int)(CLOCK_TICK_RATE/parms.freq)) < 0) {
+- printf("\a"); /* Output the only beep we can, in an effort to fall back on usefulness */
+- perror("ioctl");
++ if (console_fd >= 0) {
++ ioctl(console_fd, KIOCSOUND, (int)(CLOCK_TICK_RATE/parms.freq));
++ } else {
++ printf("\a"); /* Output the fall back for usefulness we don't have to be suid to work at all */
++ fflush(stdout);
+ }
+ /* Look ma, I'm not ansi C compatible! */
+ usleep(1000*parms.length); /* wait... */
+- ioctl(console_fd, KIOCSOUND, 0); /* stop beep */
++ if (console_fd >= 0)
++ ioctl(console_fd, KIOCSOUND, 0); /* stop beep */
+ if(parms.end_delay || (i+1 < parms.reps))
+ usleep(1000*parms.delay); /* wait... */
+ } /* repeat. */
diff --git a/app-misc/beep/metadata.xml b/app-misc/beep/metadata.xml
new file mode 100644
index 000000000000..f23b9cae1593
--- /dev/null
+++ b/app-misc/beep/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>