summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/g15mpd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/g15mpd/files')
-rw-r--r--app-misc/g15mpd/files/g15mpd-1.0.0-cflags-and-lib-fix.patch18
-rw-r--r--app-misc/g15mpd/files/g15mpd-1.0.0-libmpd.patch34
2 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/g15mpd/files/g15mpd-1.0.0-cflags-and-lib-fix.patch b/app-misc/g15mpd/files/g15mpd-1.0.0-cflags-and-lib-fix.patch
new file mode 100644
index 000000000000..5bdb1261f367
--- /dev/null
+++ b/app-misc/g15mpd/files/g15mpd-1.0.0-cflags-and-lib-fix.patch
@@ -0,0 +1,18 @@
+diff -ruN g15mpd-1.0.0/Makefile.am g15mpd-1.0.0-patched/Makefile.am
+--- g15mpd-1.0.0/Makefile.am 2014-01-17 13:43:28.536056492 -0500
++++ g15mpd-1.0.0-patched/Makefile.am 2014-01-17 13:43:31.596056410 -0500
+@@ -1,12 +1,12 @@
+ AM_CPPFLAGS = @libmpd_CFLAGS@
+-AM_CFLAGS = -O3 -Wall @CFLAGS@ -I$(top_builddir) -I$(top_srcdir)
++AM_CFLAGS = @CFLAGS@ -I$(top_builddir) -I$(top_srcdir)
+ METASOURCES = AUTO
+ bin_PROGRAMS = g15mpd
+
+ docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
+ doc_DATA = README ChangeLog AUTHORS NEWS COPYING
+
+-LIBS = -lg15daemon_client -lg15render -lX11 -lXtst @libmpd_LIBS@
++LIBS = -lpthread -lg15daemon_client -lg15render -lX11 -lXtst @libmpd_LIBS@
+ IMCLUDES = -I
+ g15mpd_LDFLAGS = -avoid-version
+ g15mpd_SOURCES = g15mpd.c
diff --git a/app-misc/g15mpd/files/g15mpd-1.0.0-libmpd.patch b/app-misc/g15mpd/files/g15mpd-1.0.0-libmpd.patch
new file mode 100644
index 000000000000..57d2fb8a1ef6
--- /dev/null
+++ b/app-misc/g15mpd/files/g15mpd-1.0.0-libmpd.patch
@@ -0,0 +1,34 @@
+diff --git a/Makefile.am b/Makefile.am
+index e407dab..6404618 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,4 +1,4 @@
+-
++AM_CPPFLAGS = @libmpd_CFLAGS@
+ AM_CFLAGS = -O3 -Wall @CFLAGS@ -I$(top_builddir) -I$(top_srcdir)
+ METASOURCES = AUTO
+ bin_PROGRAMS = g15mpd
+@@ -6,7 +6,7 @@ bin_PROGRAMS = g15mpd
+ docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
+ doc_DATA = README ChangeLog AUTHORS NEWS COPYING
+
+-LIBS = -lg15daemon_client -lg15render -lX11 -lXtst -lmpd
++LIBS = -lg15daemon_client -lg15render -lX11 -lXtst @libmpd_LIBS@
+ IMCLUDES = -I
+ g15mpd_LDFLAGS = -avoid-version
+ g15mpd_SOURCES = g15mpd.c
+diff --git a/configure.in b/configure.in
+index aaa361c..83281d0 100644
+--- a/configure.in
++++ b/configure.in
+@@ -18,7 +18,9 @@ AC_HEADER_SYS_WAIT
+ AC_CHECK_HEADERS(g15daemon_client.h libg15render.h,,AC_MSG_ERROR(["libg15daemon_client (or its devel package) could not be found. please install it"]))
+ AC_CHECK_HEADERS(X11/Xlib.h X11/XF86keysym.h,,AC_MSG_ERROR(["Xorg development files could not be found. please install the devel package"]))
+ AC_CHECK_HEADERS(X11/extensions/XTest.h,,AC_MSG_ERROR(["Xorg XTEST Extension devel headers could not be found. please install the devel package"]))
+-AC_CHECK_HEADERS(libmpd/libmpd.h,,AC_MSG_ERROR(["libmpd development files could not be found. please install the libmpd devel package"]))
++PKG_CHECK_MODULES([libmpd], [libmpd])
++AC_SUBST(libmpd_LIBS)
++AC_SUBST(libmpd_CFLAGS)
+ AC_PATH_X
+
+ AC_OUTPUT(Makefile)