summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-07-16 16:10:06 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-07-17 14:33:35 +0200
commitb3182179fccd82e224a8d1cf18a31b47983b2cad (patch)
tree09fc424963d0eacd25c11e70e8a39733d56432e9 /app-misc/openrgb
parentapp-misc/openrgb: add 0.9 (diff)
downloadgentoo-b3182179fccd82e224a8d1cf18a31b47983b2cad.tar.gz
gentoo-b3182179fccd82e224a8d1cf18a31b47983b2cad.tar.bz2
gentoo-b3182179fccd82e224a8d1cf18a31b47983b2cad.zip
app-misc/openrgb: sync live
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-misc/openrgb')
-rw-r--r--app-misc/openrgb/openrgb-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/app-misc/openrgb/openrgb-9999.ebuild b/app-misc/openrgb/openrgb-9999.ebuild
index 291cae9fb808..0b3ebc85f6c8 100644
--- a/app-misc/openrgb/openrgb-9999.ebuild
+++ b/app-misc/openrgb/openrgb-9999.ebuild
@@ -12,14 +12,15 @@ else
SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
S="${WORKDIR}/OpenRGB-release_${PV}"
KEYWORDS="~amd64 ~loong ~x86"
- PATCHES=( "${FILESDIR}"/OpenRGB-0.5-build-system.patch )
+ PATCHES=( "${FILESDIR}"/OpenRGB-0.9-build-system.patch )
fi
DESCRIPTION="Open source RGB lighting control"
HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
LICENSE="GPL-2"
-# subslot is OPENRGB_PLUGIN_API_VERSION from https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
-SLOT="0/2"
+# subslot is OPENRGB_PLUGIN_API_VERSION from
+# https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
+SLOT="0/3"
RDEPEND="
dev-cpp/cpp-httplib:=
@@ -42,6 +43,7 @@ BDEPEND="
PATCHES+=(
"${FILESDIR}"/OpenRGB-0.7-r1-udev.patch
+ "${FILESDIR}"/OpenRGB-0.9-udev-check.patch
)
src_prepare() {
@@ -52,8 +54,8 @@ src_prepare() {
src_configure() {
# Some plugins require symbols defined in the main binary.
- # The official build system bundles OpenRGB as a submodule instead, and
- # compiles the .cpp file again.
+ # The upstream build system of plugins bundles OpenRGB as a submodule
+ # instead, and compiles the .cpp file again.
append-ldflags -Wl,--export-dynamic
# > warning: ‘-pipe’ ignored because ‘-save-temps’ specified
@@ -70,8 +72,8 @@ src_install() {
dodoc README.md OpenRGB.patch
- udev_dorules 60-openrgb.rules
rm -r "${ED}"/usr/lib/udev/ || die
+ udev_dorules 60-openrgb.rules
# This is for plugins. Upstream doesn't install any headers at all.
insinto /usr/include/OpenRGB